Bug 1271358 - ECVOL: glustershd log grows quickly and fills up the root volume
ECVOL: glustershd log grows quickly and fills up the root volume
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: disperse (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ashish Pandey
: ZStream
Depends On: 1264804
Blocks: 1271967
  Show dependency treegraph
 
Reported: 2015-10-13 14:25 EDT by Ashish Pandey
Modified: 2016-06-23 04:43 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.8.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1264804
: 1271967 (view as bug list)
Environment:
Last Closed: 2016-06-23 04:43:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-10-13 14:28:42 EDT
REVIEW: http://review.gluster.org/12353 (cluster/ec : Remove index entries if file/dir does not exist) posted (#2) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 2 Vijay Bellur 2015-10-14 06:08:27 EDT
REVIEW: http://review.gluster.org/12353 (cluster/ec : Remove index entries if file/dir does not exist) posted (#3) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 3 Vijay Bellur 2015-10-15 02:30:04 EDT
REVIEW: http://review.gluster.org/12353 (cluster/ec : Remove index entries if file/dir does not exist) posted (#4) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 4 Vijay Bellur 2015-10-15 03:52:23 EDT
REVIEW: http://review.gluster.org/12353 (cluster/ec : Remove index entries if file/dir does not exist) posted (#5) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 5 Vijay Bellur 2015-10-16 01:24:40 EDT
COMMIT: http://review.gluster.org/12353 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 0f31ab1ba9bb7dbc47bfa68cbce81ec104d04ac4
Author: Ashish Pandey <aspandey@redhat.com>
Date:   Tue Oct 13 23:25:59 2015 +0530

    cluster/ec : Remove index entries if file/dir does not exist
    
    Problem: During write and rebalance if a brick is down, index
    entries will be created. If the same file gets migrated to
    other subvol by rebalance process, these index entries will
    remain in index directory. During heal, these indices should
    be removed when we get ENOENT or ESTALE for a index.
    
    Solution: Capture correct errno and take appropriate action
    to purge these indices.
    
    Change-Id: I1aad8b99e4df2e139648e3bf971e4cb1c4b38699
    Bug: 1271358
    Signed-off-by: Ashish Pandey <aspandey@redhat.com>
    Reviewed-on: http://review.gluster.org/12353
    Reviewed-by: Xavier Hernandez <xhernandez@datalab.es>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 6 Niels de Vos 2016-06-23 04:43:13 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1] a while back, and packages for several distributions should be available by now.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/

Note You need to log in before you can comment on or make changes to this bug.