Bug 127137 - w8c2q2 wrong grep command line switch
Summary: w8c2q2 wrong grep command line switch
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Academy
Classification: Retired
Component: RHA030 Curriculum (Show other bugs)
(Show other bugs)
Version: 2.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bowe Strickland
QA Contact: Bowe Strickland
URL:
Whiteboard:
Keywords:
: 123046 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-02 14:17 UTC by Bowe Strickland
Modified: 2007-04-18 17:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-07 17:30:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bowe Strickland 2004-07-02 14:17:18 UTC
2.  To allow the search pattern HELLO to match both hello and HELLO, 
you would use the grep command with which command line switch? 
   A.  -w  
   B.  -r  
X C.  -i  
   D.  -k  
   E.  None of the above  

The 'test' claims that answer 'A' is correct:
     "-w" is match whole word.

But the correct answer is really:
     "-i" is ignore case. 

The question is about case not about word boundry,
which would be something like:
     "HELLO" verus "HELLOTHERE"

Comment 1 Bowe Strickland 2005-01-03 21:30:50 UTC
*** Bug 123046 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.