Bug 1271380 - chrpath missing support for 32-bit binaries
chrpath missing support for 32-bit binaries
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: chrpath (Show other bugs)
7.1
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Jeff Law
Martin Cermak
Vladimír Slávik
: Patch, Rebase
Depends On:
Blocks: 1298243 1390370
  Show dependency treegraph
 
Reported: 2015-10-13 15:37 EDT by Deepu K S
Modified: 2017-08-01 18:23 EDT (History)
13 users (show)

See Also:
Fixed In Version: chrpath-0.16-0.el7
Doc Type: Rebase: Bug Fixes Only
Doc Text:
_chrpath_ rebased to version 0.16 The _chrpath_ package has been upgraded to upstream version 0.16, which provides a number of bug fixes over the previous version. Notably, the *chrpath* tool could only modify the run path property of 64-bit binaries on 64-bit systems, and 32-bit binaries on 32-bit systems. This bug has been fixed, and *chrpath* on a 64-bit system can now modify run paths of binaries for a 32-bit system and binaries for a 32-bit system on a 64-bit system.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 18:23:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Diff of chrpath-0.13 and chrpath-0.14 (13.21 KB, patch)
2015-10-14 04:50 EDT, Divya
no flags Details | Diff

  None (edit)
Description Deepu K S 2015-10-13 15:37:38 EDT
Description of problem:
Current `chrpath` in RHEL 7 doesn't support for 32-bit executables/libraries.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux 7.1
chrpath-0.13-14.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. chrpath -l <executable/library>

Actual results:
# chrpath -l program_32 
`program_32' probably isn't a 64-bit LSB-first ELF file.
elf_open: Exec format error

# chrpath -r /root/D program_32 
`program_32' probably isn't a 64-bit LSB-first ELF file.
elf_open: Exec format error

Expected results:
# chrpath -l program_32 
program_32: RPATH=/root/C/

# chrpath -r /root/D program_32 
program_32: RPATH=/root/C
program_32: new RPATH: /root/D

Additional info:
Upstream BugZilla : https://bugzilla.redhat.com/show_bug.cgi?id=1144863
Comment 1 Divya 2015-10-14 04:50 EDT
Created attachment 1082750 [details]
Diff of chrpath-0.13 and chrpath-0.14

Tested locally, it seems to fix the issue.
Comment 43 errata-xmlrpc 2017-08-01 18:23:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2058

Note You need to log in before you can comment on or make changes to this bug.