Bug 1271382 - Create "Integration Components" topic under Arch/Infrastructure
Create "Integration Components" topic under Arch/Infrastructure
Status: CLOSED CANTFIX
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.1.0
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Vikram Goyal
Vikram Goyal
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-13 15:47 EDT by Alex Dellapenta
Modified: 2017-12-24 05:54 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-24 05:54:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Dellapenta 2015-10-13 15:47:59 EDT
Original GH Issue: https://github.com/openshift/openshift-docs/issues/622

Snip from Issue:

=====

I think this needs an overhaul:
https://github.com/openshift/openshift-docs/blob/master/architecture/infrastructure_components/image_registry.adoc

I would actually propose that this be subsumed in a page that discusses the components that run on top of the basic infrastructure, which include:

routers
registry
keepalived
In the near future, private git server a la gitolite
optionally some authentication pieces
possibly other admin bits, like a project creation manager
Eventually - monitoring infrastructure, log aggregators, continuous integration, etc etc

These might deserve separate pages eventually, but for now I think it would be a good idea to discuss them in one place, separately from the master/nodes stuff. Partly because the great thing about all this is that using the infrastructure it can all be made redundant and HA without a great deal of trouble.

=====

I think this is still worth doing. Structure-wise, suggest something like (note slightly different naming of existing titles as well):

Architecture
  Overview
  Infrastructure
      Kubernetes Components
      Integration Components [1]
      Web Console
  Core Concepts
    ...
  Additional Concepts
    ...

[1] new topic as mentioned above; could become a subsection down the road
Comment 5 Vikram Goyal 2017-12-24 05:54:42 EST
This topic was removed from the latest guides. I am going to close this bug. If a new restructure is required or if this topic needs adding, please open a new bug.

Note You need to log in before you can comment on or make changes to this bug.