Bug 1271383 - (CVE-2015-7625, CVE-2015-7626, CVE-2015-7627, CVE-2015-7629, CVE-2015-7630, CVE-2015-7631, CVE-2015-7632, CVE-2015-7633, CVE-2015-7634, CVE-2015-7635, CVE-2015-7636, CVE-2015-7637, CVE-2015-7638, CVE-2015-7639, CVE-2015-7640, CVE-2015-7641, CVE-2015-7642, CVE-2015-7643, CVE-2015-7644) flash-plugin: multiple code execution issues fixed in APSB15-25
flash-plugin: multiple code execution issues fixed in APSB15-25
Status: CLOSED ERRATA
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Red Hat Product Security
impact=critical,public=20151013,repor...
: Security
Depends On: 1271384 1271385 1271386
Blocks: 1271390
  Show dependency treegraph
 
Reported: 2015-10-13 15:48 EDT by Tomas Hoger
Modified: 2015-11-11 06:40 EST (History)
5 users (show)

See Also:
Fixed In Version: flash-plugin 11.2.202.535
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-11 06:40:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Hoger 2015-10-13 15:48:34 EDT
Adobe Security Bulletin APSB15-25 for Adobe Flash Player describes multiple flaws that can possibly lead to code execution when Flash Player is used to play a specially crafted SWF file.

Quoting from the APSB15-25:

These updates resolve use-after-free vulnerabilities that could lead to code execution (CVE-2015-7629, CVE-2015-7631, CVE-2015-7643, CVE-2015-7644).

These updates resolve a buffer overflow vulnerability that could lead to code execution (CVE-2015-7632).

These updates resolve memory corruption vulnerabilities that could lead to code execution (CVE-2015-7625, CVE-2015-7626, CVE-2015-7627, CVE-2015-7630, CVE-2015-7633, CVE-2015-7634).

External References:

https://helpx.adobe.com/security/products/flash-player/apsb15-25.html
Comment 2 errata-xmlrpc 2015-10-15 07:18:05 EDT
This issue has been addressed in the following products:

  Supplementary for Red Hat Enterprise Linux 6

Via RHSA-2015:1893 https://rhn.redhat.com/errata/RHSA-2015-1893.html
Comment 3 Tomas Hoger 2015-10-16 03:54:26 EDT
APSB15-25 was updated on Oct14 to list additional CVEs which were previously omitted.  Revision notes of the Bulletin includes this info:

  October 14, 2015: Added CVEs credited to Yuki Chen of Qihoo 360 Vulcan Team

The following section of the Bulletin was updated with additional CVEs:

These updates resolve use-after-free vulnerabilities that could lead to code execution (CVE-2015-7629, CVE-2015-7631, CVE-2015-7635, CVE-2015-7636, CVE-2015-7637, CVE-2015-7638, CVE-2015-7639, CVE-2015-7640, CVE-2015-7641, CVE-2015-7642, CVE-2015-7643, CVE-2015-7644).
Comment 4 Tomas Hoger 2015-11-06 03:31:57 EST
APSB15-25 was updated on Nov5 to indicate that the CVE-2015-7634 issue, originally listed as memory corruption problem, was determined to be limited to a NULL pointer dereference crash.  Therefore, it is no longer considered to be a security flaw and was removed from the bulletin.

  November 5, 2015: Removed CVE-2015-7634 from the bulletin.  This CVE was
  originally classified as a memory corruption issue, but has since been
  reclassified as a non-exploitable null pointer dereference bug.
Comment 5 errata-xmlrpc 2015-11-11 06:21:35 EST
This issue has been addressed in the following products:

  Supplementary for Red Hat Enterprise Linux 5

Via RHSA-2015:2024 https://rhn.redhat.com/errata/RHSA-2015-2024.html

Note You need to log in before you can comment on or make changes to this bug.