Bug 1271398 - tool stopped working after update to version 6.7
tool stopped working after update to version 6.7
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Adam Jackson
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-13 16:58 EDT by john_j_ferrier
Modified: 2016-05-10 15:55 EDT (History)
2 users (show)

See Also:
Fixed In Version: xorg-x11-server-1.17.4-8.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 15:55:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of the correct result. (1.56 MB, image/png)
2015-10-13 16:58 EDT, john_j_ferrier
no flags Details
screenshot of the unexpected result. (1.55 MB, image/png)
2015-10-13 17:00 EDT, john_j_ferrier
no flags Details
updates that cause a problem (121.04 KB, image/png)
2015-10-15 09:17 EDT, john_j_ferrier
no flags Details

  None (edit)
Description john_j_ferrier 2015-10-13 16:58:42 EDT
Created attachment 1082621 [details]
screenshot of the correct result.

Description of problem:

After updating to RHEL 6.7, one of my frequently used tools stopped working.

Version-Release number of selected component (if applicable):

Previous 6.6, current 6.7

How reproducible:

download "SU 44 Full Source Code" from http://www.cwp.mines.edu/cwpcodes/. uncompress and untar the compressed tarfile, then go to directory "src" and
Compile the code according to the installation guide.

Steps to Reproduce:
1. generate a binary data file with the following C++ code:
=========================================

#include <stdlib.h>
#include <stdio.h>

int main()
{
    float value[10000];

    FILE *fp = fopen("test.dat", "wb");

    for (int i = 0; i < 10000; i++)
        value[i] = i;

    fwrite(value, sizeof(float), 10000, fp);

    fclose(fp);
    return 0;
}
=========================================

2. run "/your_installation_path/xcontour n1=100 < test.dat"
3. a window popped out with contour displayed if under RHEL 6.6 but no contour displayed if under RHEL 6.7 (even when the executable is complied under RHEL 6.7).


Actual results: only popped out a window (see attached "snapshot_RHEL6.7.png", which looks like a snapshot of some parts of other windows).


Expected results:popped a window with contour displayed (see attached "snapshot_RHEL6.6.png").


Additional info:

I am sorry that the duplication procedures are not simple. Please contact me if you need any help!


Thank you,

JF
Comment 1 john_j_ferrier 2015-10-13 17:00 EDT
Created attachment 1082622 [details]
screenshot of the unexpected result.
Comment 3 john_j_ferrier 2015-10-15 09:17 EDT
Created attachment 1083257 [details]
updates that cause a problem

updates that cause a problem
Comment 4 john_j_ferrier 2015-10-15 09:18:53 EDT
reinstalled RHEL 6.6 and my problem solved. So it's one or several of these updates cause(s) my problem.

Please investigate!!!
Comment 5 john_j_ferrier 2015-10-15 09:20:05 EDT
reinstalled RHEL 6.6 and my problem solved. So it's one or several of these updates cause(s) my problem.

Please investigate!!!
Comment 10 errata-xmlrpc 2016-05-10 15:55:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0761.html

Note You need to log in before you can comment on or make changes to this bug.