Bug 1271399 - Openmpi-devel package doesn't update $PATH
Openmpi-devel package doesn't update $PATH
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openmpi (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Doug Ledford
Fedora Extras Quality Assurance
:
: 1315343 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-13 17:00 EDT by Jon
Modified: 2016-03-07 11:35 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-20 14:11:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon 2015-10-13 17:00:05 EDT
Description of problem:
After installing openmpi-devel and trying to run mpicc I found that the command was not found. After a little digging I found the binary in /usr/lib64/openmpi/bin which was not added to my path. It would be nice if the package either put the binaries somewhere where I could use them or if it updated my path so I could use them.

Version-Release number of selected component (if applicable):
Fedora 22
openmpi - current version as of Oct 13 2015


How reproducible:
Very


Steps to Reproduce:
1. Install openmpi-devel
2. type 'mpicc'
3. ???
4. Profit

Actual results:
Command not found

Expected results:
Command not found

Additional info:
Comment 1 Orion Poplawski 2015-10-13 23:01:33 EDT
We're probably long overdue for a readme file on this.  But you need to do:

module load mpi/openmpi-x86_64

in order to use openmpi.
Comment 2 Doug Ledford 2015-10-20 14:11:45 EDT
Probably right about the README.  Closing bug out as the mpi stack is working according to the MPI packaging spec.
Comment 3 Orion Poplawski 2016-03-07 11:35:52 EST
*** Bug 1315343 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.