Bug 127141 - Running genhdlist makes kickstart fail.
Running genhdlist makes kickstart fail.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-02 11:38 EDT by Matthew Jamison
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-06 18:21:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Jamison 2004-07-02 11:38:32 EDT
Kickstart not working after running /usr/lib/anaconda-
runtime/genhdlist 

I have been using EL30 and EL30 UP1 withouth any problmes for months. 
I downloaded RHEL 3.0 UP2 and moved the content to an NFS server.  I 
then ran /usr/lib/anaconda-runtime/genhdlist on the newly added 
directory and kickstart fails.  /usr/lib/anaconda-runtime/genhdlist 
completed correctly without errors and the new hdlist and hdlist2 
files were created. 
 
The way that it fails is it tries installs all the RPM's but it does 
is in alphabetical order instead of using some method of intelligent 
ordering.  For some reason because of this the system does not 
install the kernel and can not reboot. If I do not run 
the /usr/lib/anaconda-runtime/genhdlist or restore the original 
hdlist and hdlist2 in the base directory kickstart works fine.
Comment 1 Rob Schreurs 2004-07-05 05:05:04 EDT
Hi there,

The same problem exists here. I am testing kicstart to see whether we
can use it to install RedHat servers. Looks fine, but when i run 
genhdlist the installation fails. 

I am doing a base install including printing from a ftp server:
I have already searched for errors and found the following:
In the install.log errors exist for all of the rpm files which 
normally exist on disc 2:
Errors are:
error: %post(a2ps-4.13b-28) scriptlet failed, exit status 255
These errors repeat for all of the packages on disc2

If have watched the installation process on ttys2: 
on /mnt/sysimage/var/tmp the installation retrieves the RPM's before 
applying them. These files are not growing and stay at 0 bytes!
This may not be of use, but this is what i observed

In the ftp server log the rpm's that fail looks like they are 
retrieved, but as mentioned above, the installation fails.

Hope that this is solved soon!

Comment 2 Jeremy Katz 2004-07-06 18:21:15 EDT
You didn't run pkgorder and then rerun your genhdlist to generate the
hdlist with the package ordering.
Comment 3 Matthew Jamison 2004-07-06 18:26:02 EDT
I did this as a workaround but I did not see any documentation that 
stated the functionality of genhdlist had changed.  The older version 
of EL 3.0 you did not have to do this.

Note You need to log in before you can comment on or make changes to this bug.