Bug 127142 - gnbd_import -r: hangs with uncached devices
Summary: gnbd_import -r: hangs with uncached devices
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: gfs   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ben Marzinski
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-02 16:07 UTC by Derek Anderson
Modified: 2010-01-12 02:54 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-14 19:59:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Derek Anderson 2004-07-02 16:07:54 UTC
Description of problem:
If you try to unimport imported, uncached devices the command hangs. 
The gnbd_recvd process is ending, looks like the gnbd_monitor process
is not.

Version-Release number of selected component (if applicable):


How reproducible:
Yes.

Steps to Reproduce:
1. (exporter) gnbd_export -d /dev/GFSVG/lvol1 -e IMPORTME
2. (importer) gnbd_import -i exporter
3. (importer) gnbd_import -R
  
Actual results:
gnbd_import process hangs.

Expected results:
Removal of all imported devices.

Additional info:

Comment 1 Ben Marzinski 2004-07-06 16:36:16 UTC
gnbd_monitor did not start up the unix socket correctly in cvs version
1.3 of gnbd_monitor.c.  This is fixed now.

Comment 2 Dean Jansa 2004-07-14 19:59:31 UTC
Verified... 
 
[root@tank-02 gnbd]# gnbd_import -i tank-01 
gnbd_import: created gnbd device IMPORTME 
gnbd_monitor: gnbd_monitor started. Monitoring device #0 
gnbd_recvd: gnbd_recvd started 
[root@tank-02 gnbd]# gnbd_import -R 
gnbd_import: removed gnbd device IMPORTME 
[root@tank-02 gnbd]# 


Note You need to log in before you can comment on or make changes to this bug.