Bug 127143 - Blank screen when starting X with Radeon X800
Blank screen when starting X with Radeon X800
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-02 12:33 EDT by Andrew May
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-05 17:09:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf generated by installer (2.65 KB, text/plain)
2004-07-02 12:35 EDT, Andrew May
no flags Details
xorg log from blank screen (90.56 KB, text/plain)
2004-07-02 12:37 EDT, Andrew May
no flags Details

  None (edit)
Description Andrew May 2004-07-02 12:33:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040626 Firefox/0.9.1

Description of problem:
New installation of Fedora Core 2 (64bit) on a Athlon 64 3500+ with a
Radeon X800 Pro. I was unable to use the graphical installation
because when the installer tried to start X I got a blank screen which
I could not exit from.

Installed using the text installer, but was initially unable to log in
because the boot switched to a graphical mode and I got the blank screen.

Was able to boot and login after removing the "rhgb" option and
specifying runlevel 3.

Trying to start X gets the same blank screen which I am unable to get
out of (CTRL+ALT+Backspace does nothing) - I am only able to reboot
using CTRL+ALT+Delete.

When configuring X the graphics card was not recognised so it is
trying to use the vesa driver. I did select my monitor (Viewsonic P95f+). 

I am attaching xorg.conf and Xorg.0.log.

I was able to get an X desktop when using the latest version of
Knoppix (which I belive is using XFree86). I have tried copying some
of the options (e.g. mode lines for the monitor) to xorg.conf, but
this has had no effect.

I have tried using the radeon driver, but then X fails to start at all
(I think because it doesn't recognise the videocard as one it supports).


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start X, either at boot time or using "startx"

    

Additional info:
Comment 1 Andrew May 2004-07-02 12:35:49 EDT
Created attachment 101602 [details]
xorg.conf generated by installer
Comment 2 Andrew May 2004-07-02 12:37:13 EDT
Created attachment 101603 [details]
xorg log from blank screen
Comment 3 Mike A. Harris 2004-07-05 17:09:32 EDT
Radeon X800 is not yet supported by the X.Org X server, so the
installer defaults to configuring the "vesa" driver and relies on
the video card BIOS to set up the card and to set video modes, etc.

It is possible that the next release of X.Org X11 might support
this card, however it's too early to say just yet.  Once support
is available in a new X.Org X11 release, a future Fedora Core
release may support this card also.

Closing as "NOTABUG".

Note You need to log in before you can comment on or make changes to this bug.