Bug 1271433 - Horizon fails to load
Horizon fails to load
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: rdo-manager (Show other bugs)
Liberty
Unspecified Unspecified
unspecified Severity high
: ---
: Liberty
Assigned To: Giulio Fidente
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-13 20:40 EDT by Marius Cornea
Modified: 2016-04-18 02:57 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-0.8.7-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-30 19:02:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
horizon traceback (2.10 KB, text/plain)
2015-10-13 20:40 EDT, Marius Cornea
no flags Details
debug trace.html (229.39 KB, text/html)
2015-10-15 10:40 EDT, John Trowbridge
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 235418 None None None Never

  None (edit)
Description Marius Cornea 2015-10-13 20:40:10 EDT
Created attachment 1082653 [details]
horizon traceback

Description of problem:
I'm running an RDO Manager deployment with 3 ctrls and 1 compute and overcloud Horizon is throwing a 500 error. 

Version-Release number of selected component (if applicable):
python-django-horizon-8.0.0.0-rc1.el7.centos.noarch
openstack-dashboard-8.0.0.0-rc1.el7.centos.noarch

How reproducible:
100%

Steps to Reproduce:
1. Run a deployment with 3 controllers and 1 compute with network isolation
2. Access Horizon on the public VIP

Actual results:
Something went wrong! screen

Expected results:
Login prompt shows up

Additional info:
Attaching tracebak.
Comment 1 Mike Orazi 2015-10-14 16:45:14 EDT
Matthias,

Can we get some help understanding the root cause here?
Comment 2 Matthias Runge 2015-10-15 02:04:25 EDT
Unfortunately, the traceback does not tell anything useful.

First rule, to get a more usable trace would be to enable debug:
/etc/openstack-dashboard/local_settings 
set DEBUG = True
and restart httpd

Probably unrelated, there has been a rc2 release, which had many bugs fixed. I strongly recommend to test that version.
Comment 3 John Trowbridge 2015-10-15 10:40 EDT
Created attachment 1083298 [details]
debug trace.html
Comment 4 John Trowbridge 2015-10-15 10:43:19 EDT
Looks like we are configuring memcached for horizon incorrectly. I verified that if I put a single value for CACHES['LOCATION'] like:

CACHES = {
    'default': {
        'BACKEND': 'django.core.cache.backends.locmem.LocMemCache',



        'LOCATION': '192.0.2.18:11211',


    }
}


I was able to get a login page.
Comment 5 Alan Pevec 2015-10-15 11:01:01 EDT
Extracting from debug trace what does not work:
CACHES	
{'default': {'BACKEND': 'django.core.cache.backends.locmem.LocMemCache',
             'LOCATION': ['192.0.2.18:11211',
                          '192.0.2.17:11211',
                          '192.0.2.19:11211']}}
Comment 6 Alan Pevec 2015-10-15 11:11:55 EDT
Notes from IRC:
python-django-1.8.4-1.el7.noarch
https://docs.djangoproject.com/en/1.8/topics/cache/
<trown> gfidente: confirmed setting .memcached.MemcachedCache allowed it to start with list
<gfidente> should be https://review.openstack.org/235418
Comment 7 Matthias Runge 2015-10-15 15:07:32 EDT
CACHES = {
    'default': {
        'BACKEND': 'django.core.cache.backends.memcached.MemcachedCache',
        'LOCATION': '127.0.0.1:11211',
    }
}

is correct, but be sure to install
python-memcached
Comment 13 Alan Pevec 2015-10-19 11:13:45 EDT
Move to modified only when build is done in CBS.

Note You need to log in before you can comment on or make changes to this bug.