Bug 1271449 - "Covscan test" failures in errata RHBA-2015:20444-05 libnfsidmap bug fix update
"Covscan test" failures in errata RHBA-2015:20444-05 libnfsidmap bug fix update
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libnfsidmap (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Steve Dickson
Yongcheng Yang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-13 22:39 EDT by Yongcheng Yang
Modified: 2016-11-03 22:08 EDT (History)
3 users (show)

See Also:
Fixed In Version: libnfsidmap-0.25-15.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 22:08:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Steve Dickson 2016-04-07 11:23:32 EDT
commit e22368f6a6651e23d537f92ab5dec0ea37de8fa5
Author: Steve Dickson <steved@redhat.com>
Date:   Thu Apr 7 11:20:40 2016 -0400

    nss.c: wrong check of return value
    
    Fixed some NEGATIVE_RETURNS that a Covscan scan found.
    
    Signed-off-by: Steve Dickson <steved@redhat.com>
Comment 6 Steve Dickson 2016-08-17 13:58:08 EDT
The upstream commit 

commit bc494fc468d257eb7b89417d055de7f9764b77ec
Author: Steve Dickson <steved@redhat.com>
Date:   Wed Aug 17 13:33:40 2016 -0400

    nss_getpwnam: correctly check for negative values in unsigned ints.
Comment 7 Yongcheng Yang 2016-08-18 04:36:43 EDT
Have checked the newly "Covscan test" passed for libnfsidmap-0.25-15.el7 comparing to libnfsidmap-0.25-12.el7. Thanks for the work.

http://cov01.lab.eng.brq.redhat.com/covscanhub/waiving/et_mapping/15055/

https://errata.devel.redhat.com/advisory/23209/test_run/covscan

So move this bug to VERIFIED
Comment 9 errata-xmlrpc 2016-11-03 22:08:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2272.html

Note You need to log in before you can comment on or make changes to this bug.