Bug 1271455 - GNOME terminal transparency is broken under wayland
GNOME terminal transparency is broken under wayland
Status: CLOSED DUPLICATE of bug 1207943
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
23
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-13 23:13 EDT by Rob Tomsick
Modified: 2015-11-22 13:31 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-22 13:31:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example of problem (1.47 MB, image/png)
2015-10-13 23:13 EDT, Rob Tomsick
no flags Details

  None (edit)
Description Rob Tomsick 2015-10-13 23:13:15 EDT
Created attachment 1082675 [details]
Example of problem

Description of problem:
---

GNOME Terminal's transparency setting is completely broken under GNOME running under Wayland.


How reproducible:
---

Always


Steps to Reproduce:
---
1. Open GNOME terminal.
2. Go to the "Profiles" tab of the Preferences window and Edit a profile.
3. Enable background transparency (via the "Colors" tab of the "Editing Profile" window.)


Actual results:
---

Terminal is rendered with artifacts, sometimes with working transparency, other times not.


Expected results:
---

Terminal background becomes transparent and correctly alpha-blended as it does under X11.


Additional info:
---

See attachment for example.
Comment 1 Olivier Fourdan 2015-10-16 09:03:47 EDT
Duplicate of bug 1207943 ?

Note, there is no transparency in gnome-terminal upstream AFAIK, this is a patch added downstream that breaks things with Wayland.
Comment 2 Rob Tomsick 2015-11-22 13:31:03 EST
(In reply to Olivier Fourdan from comment #1)
> Duplicate of bug 1207943 ?
> 
> Note, there is no transparency in gnome-terminal upstream AFAIK, this is a
> patch added downstream that breaks things with Wayland.

Sorry, I didn't find that when I first filed.  Marking as dupe.

*** This bug has been marked as a duplicate of bug 1207943 ***

Note You need to log in before you can comment on or make changes to this bug.