Bug 127146 - "chroot" can not work. :(
Summary: "chroot" can not work. :(
Status: CLOSED DUPLICATE of bug 121351
Alias: None
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
(Show other bugs)
Version: 2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-02 17:09 UTC by Lee Shih-Yuan
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:04:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lee Shih-Yuan 2004-07-02 17:09:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; zh-TW; rv:1.6) Gecko/20040122

Description of problem:
Fedora Core 2
# chroot /mnt/hda7 /bin/bash
Inconsistency detected by ld.so: rtld.c: 1192: dl_main: Assertion
`(void *) ph->p_vaddr == _rtld_local._dl_sysinfo_dso' failed!
# rpm -qf /usr/sbin/chroot
coreutils-5.2.1-7
# uname -a
Linux localhost.localdomain 2.6.6-1.435 #1 Mon Jun 14 09:09:07 EDT
2004 i686 i686 i386 GNU/Linux

Version-Release number of selected component (if applicable):
coreutils-5.2.1-7

How reproducible:
Always

Steps to Reproduce:
1.mount /dev/hda7 /mnt/hda7
2.chroot /mnt/hda7 /bin/bash
3.then fails. :(
    

Additional info:

Comment 1 Tim Waugh 2004-07-02 20:42:54 UTC
You need to boot with vdso=0 to work around this glibc bug.

*** This bug has been marked as a duplicate of 121351 ***

Comment 2 Lee Shih-Yuan 2004-07-03 08:41:56 UTC
I add vdso=0 to boot fedora core 2 ...

This time it appears "Segmentation fault". XD

Comment 3 Tim Waugh 2004-07-03 09:39:15 UTC
This is not a coreutils problem, but an already-reported glibc bug.

*** This bug has been marked as a duplicate of 121351 ***

Comment 4 Red Hat Bugzilla 2006-02-21 19:04:19 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.