Bug 1271469 - Win8. i386 guest stay on "shuting down" screen when do system_powerdown
Win8. i386 guest stay on "shuting down" screen when do system_powerdown
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.8
i386 Windows
unspecified Severity medium
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
Yehuda Zimmerman
:
Depends On:
Blocks: 1359965
  Show dependency treegraph
 
Reported: 2015-10-14 02:11 EDT by Yanan Fu
Modified: 2017-03-31 03:25 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Windows 8 virtual machines now shut down properly Previously, when powering down a Windows 8 guest virtual machine with an 32-bit AMD and Intel architecture processor, the virtual machine became unresponsive on the Shutting Down screen. With the update of *virtio* and *qxl* drivers, this has been fixed. Consequently, the shutdown process finishes as expected.
Story Points: ---
Clone Of:
: 1271937 (view as bug list)
Environment:
Last Closed: 2016-10-27 00:16:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yanan Fu 2015-10-14 02:11:49 EDT
Description of problem: 
Boot a win8.i386 guest in rhel 6.8. do "system_powerdown" in qmp, guest can not be shutdown. stay on "shuting down" screen.

Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.481.el6.x86_64
kernel:2.6.32-580.el6.x86_64

How reproducible:
1/10

Steps to Reproduce:
1.boot a win8 i386 guest in RHEL 6.8
2.do "system_power" in monitor
3.guest can not be shutdown, stay on "shuting down" screen.

Actual results:
guest can not be shutdown, stay on "shuting down" screen.

Expected results:
guest can shut down successfully.

Additional info:
commad line:
/usr/libexec/qemu-kvm \
-S  \
    -name 'virt-tests-vm1' \
    -machine rhel6.6.0  \
    -nodefaults  \
    -vga qxl \
    -device intel-hda,bus=pci.0,addr=03 \
    -device hda-duplex  \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20151012-103510-6rkrkwYs,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control  \
    -chardev socket,id=qmp_id_catch_monitor,path=/tmp/monitor-catch_monitor-20151012-103510-6rkrkwYs,server,nowait \
    -mon chardev=qmp_id_catch_monitor,mode=control \
    -device pvpanic,ioport=0x505,id=idJZDjbv  \
    -chardev socket,id=serial_id_serial0,path=/tmp/serial-serial0-20151012-103510-6rkrkwYs,server,nowait \
    -device isa-serial,chardev=serial_id_serial0  \
    -chardev socket,id=seabioslog_id_20151012-103510-6rkrkwYs,path=/tmp/seabios-20151012-103510-6rkrkwYs,server,nowait \
-device isa-debugcon,chardev=seabioslog_id_20151012-103510-6rkrkwYs,iobase=0x402 \
    -device ich9-usb-ehci1,id=usb1,addr=1d.7,multifunction=on,bus=pci.0 \
    -device ich9-usb-uhci1,id=usb1.0,multifunction=on,masterbus=usb1.0,addr=1d.0,firstport=0,bus=pci.0 \
    -device ich9-usb-uhci2,id=usb1.1,multifunction=on,masterbus=usb1.0,addr=1d.2,firstport=2,bus=pci.0 \
    -device ich9-usb-uhci3,id=usb1.2,multifunction=on,masterbus=usb1.0,addr=1d.4,firstport=4,bus=pci.0 \
    -device virtio-scsi-pci,id=virtio_scsi_pci0,bus=pci.0,addr=04 \
    -drive id=drive_image1,if=none,cache=none,snapshot=off,aio=native,format=qcow2,file=/home/autotest/client/tests/virt/shared/data/images/win8-32.1-virtio-scsi.qcow2 \
    -device scsi-hd,id=image1,drive=drive_image1 \
    -device virtio-net-pci,mac=9a:0c:0d:0e:0f:10,id=idq4s4N2,vectors=4,netdev=id7soH5K,bus=pci.0,addr=05  \
    -netdev tap,id=id7soH5K,vhost=on  \
    -m 65536  \
    -smp 32,maxcpus=32,cores=16,threads=1,sockets=2  \
    -cpu 'Opteron_G5',+sep,hv_relaxed \
    -drive id=drive_cd1,if=none,snapshot=off,aio=native,media=cdrom,file=/home/autotest/client/tests/virt/shared/data/isos/windows/winutils.iso \
    -device ide-drive,id=cd1,drive=drive_cd1,bus=ide.0,unit=0 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
    -spice port=3000,disable-ticketing,ipv4  \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=c,menu=off,strict=off \
    -enable-kvm \
    -monitor stdio \
Comment 3 Vadim Rozenfeld 2016-10-25 22:52:43 EDT
Can we try reproducing the problem with the latest virtio and qxl drivers?
If the problem is still reproducible, will it be possible to crash the system with NMI command and upload the relevant crash dump file?

Thanks,
Vadim.
Comment 4 Yiqian Wei 2016-10-26 23:39:42 EDT
 Can't reproduce this bug with latest virtio and qxl drivers.
Version:
host:
     kernel:kernel-2.6.32-642.el6.x86_64
     qemu-kvm:qemu-kvm-0.12.1.2-2.491.el6.x86_64
     virtio-win:virtio-win-1.7.5-0.el6.noarch.rpm
guest:win8-32bit
      qxlwddm-0.4-1.zip 
1.boot a guest with command
/usr/libexec/qemu-kvm \
-S  \
-name 'virt-tests-vm1' \
-machine rhel6.6.0  \
-nodefaults  \
-vga qxl \
-device intel-hda,bus=pci.0,addr=03 \
-device hda-duplex  \
-chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20151012-103510-6rkrkwYs,server,nowait \
-mon chardev=qmp_id_qmpmonitor1,mode=control  \
-chardev socket,id=qmp_id_catch_monitor,path=/tmp/monitor-catch_monitor-20151012-103510-6rkrkwYs,server,nowait \
-mon chardev=qmp_id_catch_monitor,mode=control \
-device pvpanic,ioport=0x505,id=idJZDjbv  \
-chardev socket,id=serial_id_serial0,path=/tmp/serial-serial0-20151012-103510-6rkrkwYs,server,nowait \
-device isa-serial,chardev=serial_id_serial0  \
-chardev socket,id=seabioslog_id_20151012-103510-6rkrkwYs,path=/tmp/seabios-20151012-103510-6rkrkwYs,server,nowait \
-device isa-debugcon,chardev=seabioslog_id_20151012-103510-6rkrkwYs,iobase=0x402 \
-device ich9-usb-ehci1,id=usb1,addr=1d.7,multifunction=on,bus=pci.0 \
-device ich9-usb-uhci1,id=usb1.0,multifunction=on,masterbus=usb1.0,addr=1d.0,firstport=0,bus=pci.0 \
-device ich9-usb-uhci2,id=usb1.1,multifunction=on,masterbus=usb1.0,addr=1d.2,firstport=2,bus=pci.0 \
-device ich9-usb-uhci3,id=usb1.2,multifunction=on,masterbus=usb1.0,addr=1d.4,firstport=4,bus=pci.0 \
-device virtio-scsi-pci,id=virtio_scsi_pci0,bus=pci.0,addr=04 \
-drive id=drive_image1,if=none,cache=none,snapshot=off,aio=native,format=qcow2,file=/home/win8-32.1-virtio-scsi.qcow2 \
-device scsi-hd,id=image1,drive=drive_image1 \
-m 10G  \
-smp 32,maxcpus=32,cores=16,threads=1,sockets=2  \
-cpu 'Opteron_G5',+sep,hv_relaxed \
-drive id=drive_cd1,if=none,snapshot=off,aio=native,media=cdrom,file=/home/en_windows_8_enterprise_x86_dvd_917587.iso \
-device ide-drive,id=cd1,drive=drive_cd1,bus=ide.0,unit=0 \
-device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
-spice port=3000,disable-ticketing,ipv4  \
-rtc base=localtime,clock=host,driftfix=slew  \
-boot order=cdn,once=c,menu=off,strict=off \
-enable-kvm \
-monitor stdio \
-device virtio-net-pci,mac=9a:0c:0d:0e:0f:10,id=idq4s4N2,vectors=4,netdev=id7soH5K,bus=pci.0  \
-netdev tap,id=id7soH5K,vhost=on \

2.do "system_powerdown" in monitor

Test results:
   guest can be shutdown normal.
Comment 5 Vadim Rozenfeld 2016-10-26 23:42:45 EDT
thanks a lot.
I'm going to close this bug then.
Best regards,
Vadim.

Note You need to log in before you can comment on or make changes to this bug.