This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1271488 - User with Migrate_VM permissions can't Migrate VM
User with Migrate_VM permissions can't Migrate VM
Status: CLOSED DUPLICATE of bug 1251893
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.5.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: nobody nobody
virt
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-14 03:08 EDT by Alexandros Gkesos
Modified: 2016-10-31 21:39 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-15 06:55:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandros Gkesos 2015-10-14 03:08:24 EDT
Description of problem:
User with Custom Role with Migrate_VM permissions cannot migrate a VM

All the Role's Action_Group_IDs

4 5 6 7 11 12 13 14 15 103 1300 1301 1302 1303 1304

v_MIGRATE_VM := 6;

User with the same permissions was able to do that in RHEV-M 3.4.1

Version-Release number of selected component (if applicable):
rhevm-3.5.3.1-1.4
rhevm-3.5.4.2-1.3

How reproducible:
Always

Steps to Reproduce:
1. Create a new Role
2. Add Permissions with the following Action_Group_IDs 
   4 5 6 7 11 12 13 14 15 103 1300 1301 1302 1303 1304
3. restart the engine, log in to the Portal with that user and try to migrate a VM

Actual results:

"Error while executing action:

testVM:

    User is not authorized to perform this action.

Expected results:

VM should be migrated with no errors
Comment 3 Omer Frenkel 2015-10-15 06:55:29 EDT
already solved for 3.5.5

*** This bug has been marked as a duplicate of bug 1251893 ***

Note You need to log in before you can comment on or make changes to this bug.