Bug 1271521 - ovirt-engine service cannot detect jboss version if service already run and debug port enabled
ovirt-engine service cannot detect jboss version if service already run and d...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Services (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.1
: 3.6.1
Assigned To: Martin Perina
Ondra Machacek
: CodeChange
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-14 04:18 EDT by Alon Bar-Lev
Modified: 2016-02-18 06:22 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:22:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sbonazzo: ovirt‑3.6.z?
rule-engine: planning_ack?
sbonazzo: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47306 master MERGED packaging: services: ovirt-engine: set jdwp only for the engine process Never
oVirt gerrit 47478 ovirt-engine-3.6 MERGED packaging: services: ovirt-engine: set jdwp only for the engine process Never

  None (edit)
Description Alon Bar-Lev 2015-10-14 04:18:29 EDT
we need to set debug port only for the actual instance.

---
ovirt-engine[22164] DEBUG _detectJBossVersion:240 Return code: -6, 
stdout: '[u'FATAL ERROR in native method: JDWP No transports initialized, jvmtiError=AGENT_ERROR_TRANSPORT_INIT(197)'], 
stderr: '[u'ERROR: transport error 202: bind failed: Address already in use', u'ERROR: JDWP Transport dt_socket failed to initialize, TRANSPORT_INIT(510)', u'JDWP exit error AGENT_ERROR_TRANSPORT_INIT(197): No transports initialized [debugInit.c:750]']'
ovirt-engine[22164] ERROR run:532 Error: Cannot detect JBoss version
---
Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 07:03:16 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Yaniv Lavi (Dary) 2015-10-29 08:42:39 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 3 Yaniv Lavi (Dary) 2015-11-02 10:10:31 EST
Should this be MODIFIED?

Note You need to log in before you can comment on or make changes to this bug.