Bug 1271578 - No /usr/bin/python3
No /usr/bin/python3
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: python34 (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Python Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-14 06:32 EDT by Avi Kivity
Modified: 2017-01-10 11:13 EST (History)
3 users (show)

See Also:
Fixed In Version: python34-3.4.5-3.el7.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-10 11:13:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Avi Kivity 2015-10-14 06:32:33 EDT
Description of problem:

Many python3 files start with

  #!/usr/bin/python3

but they cannot start, because there is no such name on the filesystem.


Version-Release number of selected component (if applicable):
python34-3.4.3-2.el7.x86_64

How reproducible:
Always


Steps to Reproduce:
1. python3

Actual results:
bash: python3: command not found

Expected results:
Python 3.4.3 (default, Jun 19 2015, 05:46:30) 
[GCC 4.8.3 20140911 (Red Hat 4.8.3-9)] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> 


Additional info:
Comment 2 Felix Schwarz 2017-01-10 05:25:52 EST
As of January 2017 we have python34-3.4.5-3.el7.x86_64 which provides /usr/bin/python3 so this bug can be closed (even though some people did not really like the change, see bug 1319880).

(I'm a bit hesitant to close this myself as I don't interfere with the proper EPEL maintainers.)

Note You need to log in before you can comment on or make changes to this bug.