Bug 1271579 - Automember rule expressions disappear from tables on single expression delete
Automember rule expressions disappear from tables on single expression delete
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Stanislav Laznicka
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-14 06:34 EDT by Martin Bašti
Modified: 2016-11-04 01:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: ipa-4.4.0-0.el7.1.alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 01:38:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Bašti 2015-10-14 06:34:45 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/5353

Upon deleting an expression at the automember rule page, all the expressions from both Inclusive/Exclusive tables disappear. They appear back on refresh (without the deleted expressions).

Steps to reproduce:
1. Go to an automember rule detail page
2. Create some expressions in both Inclusive/Exclusive tables
3. Delete one or more expressions from either table by selecting them and clicking "Delete".

Expected result:
The table that contained the deleted expression(s) gets updated according to the changes.

Actual result:
All expressions from both tables disappear.
Comment 2 Mike McCune 2016-03-28 19:35:19 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 4 Varun Mylaraiah 2016-09-13 09:50:44 EDT
Verified
Version : ipa-server-4.4.0-10.el7.x86_64

After deleting expressions gets updated as expected.
Comment 6 errata-xmlrpc 2016-11-04 01:38:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html

Note You need to log in before you can comment on or make changes to this bug.