Bug 1271608 - /usr/bin/net is lost after upgrading to RHEL 7.2 samba
Summary: /usr/bin/net is lost after upgrading to RHEL 7.2 samba
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: samba
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Andreas Schneider
QA Contact: Robin Hack
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-14 11:24 UTC by Jan Pazdziora
Modified: 2015-11-19 09:13 UTC (History)
7 users (show)

Fixed In Version: samba-4.2.3-9.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 09:13:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2258 normal SHIPPED_LIVE samba bug fix and enhancement update 2015-11-19 09:22:47 UTC

Description Jan Pazdziora 2015-10-14 11:24:43 UTC
Description of problem:

When working installation with /usr/bin/net from RHEL 7.1 is upgraded to RHEL 7.2, /usr/bin/net is gone.

Version-Release number of selected component (if applicable):

Upgrade from samba-common-4.1.12-21.el7_1.x86_64 to samba-common-4.2.3-7.el7.noarch.

How reproducible:

Deterministic.

Steps to Reproduce:
1. Have RHEL 7.1 machine against RHEL 7.1 repo.
2. yum install -y /usr/bin/net
3. Verify

# rpm -qf /usr/bin/net
samba-common-4.1.12-21.el7_1.x86_64

4. Switch to RHEL 7.2 (nightly) repo.
5. yum upgrade -y samba-common
6. rpm -qf /usr/bin/net

Actual results:

error: file /usr/bin/net: No such file or directory

Expected results:

Probably samba-common-tools-4.2.3-7.el7.x86_64

Additional info:

Comment 1 Jan Pazdziora 2015-10-14 11:26:14 UTC
Something like

   Obsoletes: samba-common < 4.2

in the samba-common-tools-4.2.3 package, together with renaming samba-common to something different is probably needed to ensure things are not lost during upgrade.

Comment 3 Sumit Bose 2015-10-20 14:27:26 UTC
Adding samba-tools as a dependency to samba-common might work.

Comment 7 errata-xmlrpc 2015-11-19 09:13:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2258.html


Note You need to log in before you can comment on or make changes to this bug.