Bug 1271614 - Section sect-Red_Hat_Satellite-User_Guide-AD_direct.html is gone
Section sect-Red_Hat_Satellite-User_Guide-AD_direct.html is gone
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Documentation (Show other bugs)
6.1.1
Unspecified Unspecified
urgent Severity urgent (vote)
: Unspecified
: --
Assigned To: Hayley Hudgeons
David O'Brien
: Reopened
Depends On:
Blocks: 1276400
  Show dependency treegraph
 
Reported: 2015-10-14 07:44 EDT by Jan Pazdziora
Modified: 2015-11-19 11:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1276400 (view as bug list)
Environment:
Last Closed: 2015-11-18 11:19:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2015-10-14 07:44:14 EDT
Document URL: 

https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.1/html/User_Guide/sect-Red_Hat_Satellite-User_Guide-AD_direct.html

Section Number and Name: 

Whole document.

Describe the issue: 

It was there two days ago. Today it returns 404.

Suggestions for improvement: 

Make the original URL redirect to https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.1/html/User_Guide/sect-Red_Hat_Satellite-User_Guide-Configuring_External_Authentication-Using_Active_Directory_Directly.html which seems to be the new location of that chapter.

Additional information: 

Don't break links.
Comment 7 Jan Pazdziora 2015-10-20 02:50:54 EDT
Reopening.

This is really important issue. We should not breaks links. Breaking links that are used by people privately is just as bad as breaking links in public documents.

If the build chain does not track the URL changes, the tool that deploys the new version needs to do it. Let me know if a separate bugzilla is to be filed.

For this particular issue, please add redirect from sect-Red_Hat_Satellite-User_Guide-AD_direct.html to sect-Red_Hat_Satellite-User_Guide-Configuring_External_Authentication-Using_Active_Directory_Directly.html.
Comment 15 David O'Brien 2015-11-18 21:53:35 EST
Is there a plan for implementing redirects or anything similar when we reorganize books, create new books and migrate content from other books, or delete sections or chapters that are no longer relevant?

To be clear, clean_ids didn't "break everything". It *can* touch many files and update many ids. It doesn't necessarily update 100s and 1000s every time it runs. All internal references are maintained. For the moment it's no longer used.

Note You need to log in before you can comment on or make changes to this bug.