Bug 1271615 - Accessing VMRC in Win7/Chrome browser throws unsupported plugin error
Accessing VMRC in Win7/Chrome browser throws unsupported plugin error
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Brian McLaughlin
Ramesh A
vmrc:browser
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-14 07:49 EDT by Ramesh A
Modified: 2016-06-29 11:00 EDT (History)
5 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:00:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Unsupported plugin error (49.43 KB, image/png)
2015-10-14 07:49 EDT, Ramesh A
no flags Details

  None (edit)
Description Ramesh A 2015-10-14 07:49:06 EDT
Created attachment 1082796 [details]
Unsupported plugin error

Description of problem:
Accessing VMRC in Win7/Chrome browser throws unsupported plugin error

Version-Release number of selected component (if applicable):
5.4.3.0.20151001120745_d11cf59

How reproducible:
100%

Steps to Reproduce:
1. Deploy an appliance and manage vsphere 55 provider
2. Navigate to Infrastructure ==> Virtual Machines ==> Choose a VM ==> Click on it
3. Click on the VMRC icon

Actual results:
Throws unsupported plugin error (Refer the screenshot for further details)

Expected results:
Should be able to see the vmrc screen

Additional info:
Comment 3 Brian McLaughlin 2015-10-15 09:23:29 EDT
Depending on the version of Chrome, the Client Integration plug-in may no longer be supported by Chrome.  If you are testing with the latest version of Chrome (cannot tell from the screenshot), that is the case.

Please confirm.

https://support.google.com/chrome/answer/6213033?hl=en
Comment 4 Ramesh A 2015-10-16 00:44:28 EDT
Hi Brian,

Yes I am using the latest version - 45.0.2454 and see this error.

Thanks,
Ramesh
Comment 5 Brian McLaughlin 2015-10-20 14:39:43 EDT
Thanks Ramesh!

This BZ should be closed, the latest versions of Chrome are functioning properly.  Any version of Chrome released in September 2015 or later does not support the plugin that is required for VMRC connections.


Brian
Comment 6 Brian McLaughlin 2015-12-22 11:24:56 EST
The VMRC plug-in is an NPAPI plug-in which has been phased out by Chrome.

Google Chrome disabled NPAPI plug-in support by default starting at version 42.0.2311, which was released on April 4, 2015.  To enable NPAPI plug-ins in this version of Chrome users have to visit [1] and re-enable the browser functionality.

Google Chrome removed support for NPAPI plug-ins in version 45.0.2454, which was released on September 1, 2015.

I have not been able to discover how to install previous versions of Chrome to test the specific versions noted above (information taken from release notes of the noted versions).  I did experience these steps first hand on my machine.

I have sent an email requesting the browser support for VMRC connections be updated and recommend that this BZ be closed.


[1] chrome://flags/#enable-npapi
Comment 7 Ramesh A 2016-06-01 09:41:31 EDT
Moving this issue to verified state as per the comment#6.
Comment 8 Ramesh A 2016-06-01 09:41:56 EDT
Tested in 5.6.0.8-rc1.20160524155303_f2a5a50
Comment 10 errata-xmlrpc 2016-06-29 11:00:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.