Bug 1271641 - Gnome.py:6: PyGIWarning: GnomeKeyring was imported without specifying a version first.
Gnome.py:6: PyGIWarning: GnomeKeyring was imported without specifying a versi...
Status: CLOSED DUPLICATE of bug 1259747
Product: Fedora
Classification: Fedora
Component: python-keyring (Show other bugs)
23
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Ratnadeep Debnath
Fedora Extras Quality Assurance
:
: 1283663 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-14 08:32 EDT by Pavel Raiskup
Modified: 2016-05-02 05:14 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-14 16:43:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Raiskup 2015-10-14 08:32:49 EDT
This warning appears e.g. when I hit nova command:
$ nova list
/usr/lib/python2.7/site-packages/keyring/backends/Gnome.py:6: PyGIWarning: GnomeKeyring was imported without specifying a version first. Use gi.require_version('GnomeKeyring', '1.0') before import to ensure that the right version gets loaded.
  from gi.repository import GnomeKeyring
ERROR (CommandError): You must provide a username or user id via --os-username, --os-user-id, env[OS_USERNAME] or env[OS_USER_ID]
Comment 1 Matthias Runge 2015-11-19 09:56:50 EST
Could you please update at least rawhide to something newer than 5.5.1?
Comment 2 Matthias Runge 2015-11-19 13:05:31 EST
*** Bug 1283663 has been marked as a duplicate of this bug. ***
Comment 3 Attila Fazekas 2015-11-20 11:28:36 EST
I do not see >=5.5.1 build http://koji.fedoraproject.org/koji/packageinfo?packageID=11145 .
Comment 4 Matthias Runge 2015-11-20 13:57:31 EST
Attila, there is no such build.
Comment 5 Alan Pevec 2016-01-14 16:43:25 EST

*** This bug has been marked as a duplicate of bug 1259747 ***

Note You need to log in before you can comment on or make changes to this bug.