This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1271656 - MTU/MAC not set in dracut
MTU/MAC not set in dracut
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dracut (Show other bugs)
7.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Lukáš Nykrýn
Release Test Team
:
Depends On:
Blocks: 1256306 1289485 1313485
  Show dependency treegraph
 
Reported: 2015-10-14 08:44 EDT by Jan Stodola
Modified: 2017-02-09 03:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 03:59:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Stodola 2015-10-14 08:44:18 EDT
Description of problem:
Dracut allows to set MAC address and MTU for the device being configured. However, it doesn't work in all cases, see the examples bellow:

1) format: ip=<interface>:{dhcp|on|any|dhcp6|auto6}[:[<mtu>][:<macaddr>]]

ip=ens3:dhcp:1000                       MTU:fail  MAC:N/A
ip=ens3:dhcp::54:52:00:ab:cd:ef         fails to boot: Sorry, unknown value 'ab'
ip=ens3:dhcp::[54:52:00:ab:cd:ef]       MTU:N/A   MAC:fail
ip=ens3:dhcp:1000:54:52:00:ab:cd:ef     fails to boot: Sorry, unknown value 'ab'
ip=ens3:dhcp:1000:[54:52:00:ab:cd:ef]   MTU:fail  MAC:fail


2) format: ip=<client-IP>:[<peer>]:<gateway-IP>:<netmask>:<client_hostname>:<interface>:{none|off|dhcp|on|any|dhcp6|auto6|ibft}:[:[<mtu>][:<macaddr>]]

ip=192.168.122.20::192.168.122.1:24:test:ens3:none:1000                      MTU:OK   MAC:N/A
ip=192.168.122.20::192.168.122.1:24:test:ens3:none::54:52:00:ab:cd:ef        MTU:N/A  MAC:OK
ip=192.168.122.20::192.168.122.1:24:test:ens3:none::[54:52:00:ab:cd:ef]      MTU:N/A  MAC:fail
ip=192.168.122.20::192.168.122.1:24:test:ens3:none:1000:54:52:00:ab:cd:ef    MTU:OK   MAC:fail
ip=192.168.122.20::192.168.122.1:24:test:ens3:none:1000:[54:52:00:ab:cd:ef]  MTU:OK   MAC:fail

ip=::::test:ens3:dhcp:1000                       MTU:fail  MAC:N/A
ip=::::test:ens3:dhcp::54:52:00:ab:cd:ef         MTU:N/A   MAC:fail
ip=::::test:ens3:dhcp::[54:52:00:ab:cd:ef]       MTU:N/A   MAC:fail
ip=::::test:ens3:dhcp:1000:54:52:00:ab:cd:ef     MTU:fail  MAC:fail
ip=::::test:ens3:dhcp:1000:[54:52:00:ab:cd:ef]   MTU:fail  MAC:fail

("fail" means that MTU or MAC wasn't set according to the ip= parameter)

Version-Release number of selected component (if applicable):
dracut-033-353.el7

How reproducible:
always

Steps to Reproduce:
1. try to set MAC/MTU using the examples above

Actual results:
MAC/MTU is not set

Expected results:
MAC/MTU is set correctly

Additional info:
Comment 4 Jan Stodola 2016-08-11 04:25:45 EDT
Retested with dracut-033-450.el7, all the following test cases work as expected:

ip=ens3:dhcp:1000                       MTU:OK    MAC:N/A
ip=ens3:dhcp::54:52:00:ab:cd:ef         MTU:N/A   MAC:OK
ip=ens3:dhcp::[54:52:00:ab:cd:ef]       MTU:N/A   MAC:OK
ip=ens3:dhcp:1000:54:52:00:ab:cd:ef     MTU:OK    MAC:OK
ip=ens3:dhcp:1000:[54:52:00:ab:cd:ef]   MTU:OK    MAC:OK

ip=::::test:ens3:dhcp:1000                       MTU:OK    MAC:N/A
ip=::::test:ens3:dhcp::54:52:00:ab:cd:ef         MTU:N/A   MAC:OK
ip=::::test:ens3:dhcp::[54:52:00:ab:cd:ef]       MTU:N/A   MAC:OK
ip=::::test:ens3:dhcp:1000:54:52:00:ab:cd:ef     MTU:OK    MAC:OK
ip=::::test:ens3:dhcp:1000:[54:52:00:ab:cd:ef]   MTU:OK    MAC:OK

ip=192.168.122.20::192.168.122.1:24:test:ens3:none:1000                      MTU:OK    MAC:N/A
ip=192.168.122.20::192.168.122.1:24:test:ens3:none::54:52:00:ab:cd:ef        MTU:N/A   MAC:OK
ip=192.168.122.20::192.168.122.1:24:test:ens3:none::[54:52:00:ab:cd:ef]      MTU:N/A   MAC:OK
ip=192.168.122.20::192.168.122.1:24:test:ens3:none:1000:54:52:00:ab:cd:ef    MTU:OK    MAC:OK
ip=192.168.122.20::192.168.122.1:24:test:ens3:none:1000:[54:52:00:ab:cd:ef]  MTU:OK    MAC:OK

Moving to VERIFIED.
Comment 7 errata-xmlrpc 2016-11-04 03:59:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2530.html

Note You need to log in before you can comment on or make changes to this bug.