Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1271665 - KeyError: 'vg_stacked-pool_tdata'
Summary: KeyError: 'vg_stacked-pool_tdata'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-blivet
Version: 7.2
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Vratislav Podzimek
QA Contact: Release Test Team
URL:
Whiteboard: abrt_hash:81f2fabe728f6ae58dcc01f4c54...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-14 13:04 UTC by Marian Csontos
Modified: 2016-11-03 23:51 UTC (History)
3 users (show)

Fixed In Version: python-blivet-0.61.15.47-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-03 23:51:47 UTC
Target Upstream Version:


Attachments (Terms of Use)
File: anaconda-tb (256.52 KB, text/plain)
2015-10-14 13:05 UTC, Marian Csontos
no flags Details
File: anaconda.log (15.87 KB, text/plain)
2015-10-14 13:05 UTC, Marian Csontos
no flags Details
File: environ (492 bytes, text/plain)
2015-10-14 13:05 UTC, Marian Csontos
no flags Details
File: ks.cfg (2.96 KB, text/plain)
2015-10-14 13:05 UTC, Marian Csontos
no flags Details
File: lsblk_output (10.75 KB, text/plain)
2015-10-14 13:05 UTC, Marian Csontos
no flags Details
File: nmcli_dev_list (1.20 KB, text/plain)
2015-10-14 13:05 UTC, Marian Csontos
no flags Details
File: os_info (522 bytes, text/plain)
2015-10-14 13:05 UTC, Marian Csontos
no flags Details
File: program.log (30.17 KB, text/plain)
2015-10-14 13:05 UTC, Marian Csontos
no flags Details
File: storage.log (77.84 KB, text/plain)
2015-10-14 13:05 UTC, Marian Csontos
no flags Details
File: syslog (64.40 KB, text/plain)
2015-10-14 13:05 UTC, Marian Csontos
no flags Details
File: ifcfg.log (1.25 KB, text/plain)
2015-10-14 13:05 UTC, Marian Csontos
no flags Details
script to build the LVs (5.25 KB, text/plain)
2016-02-24 13:12 UTC, Marian Csontos
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2168 0 normal SHIPPED_LIVE python-blivet bug fix and enhancement update 2016-11-03 13:15:34 UTC

Description Marian Csontos 2015-10-14 13:04:56 UTC
Description of problem:
Installation with attached disk containing thin-pool with metadata and data on RAID1.

Reproducible: 2/2

Version-Release number of selected component:
anaconda-21.48.22.54-1

The following was filed automatically by anaconda:
anaconda 21.48.22.54-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1426, in addRequiredLV
    addLV(lv_info[name])
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1477, in addLV
    addRequiredLV(name, "failed to look up raid lv")
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1566, in handleVgLvs
    addLV(lv)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1629, in handleUdevLVMPVFormat
    self.handleVgLvs(vg_device)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1981, in handleUdevDeviceFormat
    self.handleUdevLVMPVFormat(info, device)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1285, in addUdevDevice
    self.handleUdevDeviceFormat(info, device)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 2295, in _populate
    self.addUdevDevice(dev)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 2228, in populate
    self._populate()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 489, in reset
    self.devicetree.populate(cleanupOnly=cleanupOnly)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 184, in storageInitialize
    storage.reset()
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 112, in wait
    self.raise_if_error(name)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/__init__.py", line 1234, in _runThread
    threadMgr.wait(THREAD_STORAGE)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 112, in wait
    self.raise_if_error(name)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/source.py", line 682, in _initialize
    threadMgr.wait(constants.THREAD_PAYLOAD)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run
    threading.Thread.run(self, *args, **kwargs)
KeyError: 'vg_stacked-pool_tdata'

Additional info:
addons:         org_fedora_oscap, com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:     console=ttyS1 console=tty0 sysrq_always_enabled graphical ks=http://192.168.144.1/stacker_install.eqyKvY
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.10.0-322.el7.x86_64
product:        Red Hat Enterprise Linux 7
release:        Red Hat Enterprise Linux Workstation release 7.2 Beta (Maipo)
release_type:   pre-release
type:           anaconda
uid:            0
version:        7.2

Comment 1 Marian Csontos 2015-10-14 13:05:00 UTC
Created attachment 1082817 [details]
File: anaconda-tb

Comment 2 Marian Csontos 2015-10-14 13:05:02 UTC
Created attachment 1082818 [details]
File: anaconda.log

Comment 3 Marian Csontos 2015-10-14 13:05:04 UTC
Created attachment 1082819 [details]
File: environ

Comment 4 Marian Csontos 2015-10-14 13:05:05 UTC
Created attachment 1082820 [details]
File: ks.cfg

Comment 5 Marian Csontos 2015-10-14 13:05:07 UTC
Created attachment 1082821 [details]
File: lsblk_output

Comment 6 Marian Csontos 2015-10-14 13:05:09 UTC
Created attachment 1082822 [details]
File: nmcli_dev_list

Comment 7 Marian Csontos 2015-10-14 13:05:10 UTC
Created attachment 1082823 [details]
File: os_info

Comment 8 Marian Csontos 2015-10-14 13:05:12 UTC
Created attachment 1082824 [details]
File: program.log

Comment 9 Marian Csontos 2015-10-14 13:05:14 UTC
Created attachment 1082825 [details]
File: storage.log

Comment 10 Marian Csontos 2015-10-14 13:05:17 UTC
Created attachment 1082826 [details]
File: syslog

Comment 11 Marian Csontos 2015-10-14 13:05:18 UTC
Created attachment 1082827 [details]
File: ifcfg.log

Comment 13 Marian Csontos 2015-10-14 13:33:04 UTC
7.1 suffers from the same issue. :-/

Comment 15 Marian Csontos 2016-02-24 13:12:53 UTC
Created attachment 1130225 [details]
script to build the LVs

This was a complex LV setup with many different targets. Here's a script to create the layout. Edit it first. It needs 6 PVs.

Comment 16 Marian Csontos 2016-02-24 13:29:05 UTC
To run the script, there should be a VG named `vg_stacked` with 6+ PVs.
Calling function `stack_define` should do the work.
Sure the reproducer can be minimized.

Comment 18 Vratislav Podzimek 2016-05-20 13:50:06 UTC
https://github.com/rhinstaller/blivet/pull/425

Comment 19 Vratislav Podzimek 2016-05-27 09:38:25 UTC
(In reply to Vratislav Podzimek from comment #18)
> https://github.com/rhinstaller/blivet/pull/425

Merged.

Comment 21 Peter Kotvan 2016-09-06 11:58:51 UTC
Reproduced on RHEL-7.2 GA with python-blivet-1:0.61.15.37-1, verified on RHEL-7.3-20160901.1 with python-blivet-1:0.61.15.55-1. I've created the LVM stack with provided script and reinstalled the system with autopart.

Comment 23 errata-xmlrpc 2016-11-03 23:51:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2168.html


Note You need to log in before you can comment on or make changes to this bug.