Bug 1271672 - [Cinder] Delete snapshot is stuck at future.get() db transaction
[Cinder] Delete snapshot is stuck at future.get() db transaction
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity urgent (vote)
: ovirt-3.6.0-ga
: 3.6.0
Assigned To: Daniel Erez
Ori Gofen
storage
:
Depends On: 1264691
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-14 09:38 EDT by Ori Gofen
Modified: 2016-05-25 21:49 EDT (History)
6 users (show)

See Also:
Fixed In Version: ovirt-engine-3.6.0.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-04 08:36:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.0+
rule-engine: blocker+
ylavi: planning_ack+
amureini: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
log (9.14 MB, text/plain)
2015-10-14 09:38 EDT, Ori Gofen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47408 None None None Never
oVirt gerrit 47457 None None None Never

  None (edit)
Description Ori Gofen 2015-10-14 09:38:04 EDT
Created attachment 1082830 [details]
log

Description of problem:

Delete snapshot operation hangs when it reaches the part that uses Future interface of java.util.concurrent to interact with postgresql db, this bug 
is a RHEL 6.7 bug and do not reproduce on engines based on Fedora machines.

Version-Release number of selected component (if applicable):
rhevm-3.6-15

How reproducible:
100%

Steps to Reproduce:
1.delete a cinder storage snapshot

Actual results:
operation fails right after it timed out

Expected results:
operation successful

Additional info:
Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 07:03:09 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Ori Gofen 2015-11-03 08:23:58 EST
Verified on rhevm-3.6.0.2
Comment 3 Sandro Bonazzola 2015-11-04 08:36:20 EST
oVirt 3.6.0 has been released on November 4th, 2015 and should fix this issue.
If problems still persist, please open a new BZ and reference this one.

Note You need to log in before you can comment on or make changes to this bug.