Bug 1271678 - diskimage-builder should not install unit tests
diskimage-builder should not install unit tests
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: diskimage-builder (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: z3
: 7.0 (Kilo)
Assigned To: Mike Burns
Marius Cornea
: Triaged, ZStream
Depends On:
Blocks: 1271670
  Show dependency treegraph
 
Reported: 2015-10-14 09:47 EDT by Mike Burns
Modified: 2015-12-21 12:04 EST (History)
5 users (show)

See Also:
Fixed In Version: diskimage-builder-0.1.46-4.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-21 12:04:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Gerrithub.io 249772 None None None Never

  None (edit)
Description Mike Burns 2015-10-14 09:47:52 EDT
diskimage-builder is currently installing unit tests and those should not be shipped.  This is with the latest OSPd 7.1 package.
Comment 5 Marius Cornea 2015-12-09 14:59:16 EST
stack@instack:~>>> rpm -qa | grep diskimage
diskimage-builder-0.1.46-4.el7ost.noarch
stack@instack:~>>> ls -l /usr/lib/python2.7/site-packages/diskimage_builder/
total 48
-rw-r--r--. 1 root root 4751 Jun  4  2015 element_dependencies.py
-rw-r--r--. 2 root root 4632 Oct 14 10:45 element_dependencies.pyc
-rw-r--r--. 2 root root 4632 Oct 14 10:45 element_dependencies.pyo
-rw-r--r--. 1 root root    0 Jun  4  2015 __init__.py
-rw-r--r--. 2 root root  149 Oct 14 10:45 __init__.pyc
-rw-r--r--. 2 root root  149 Oct 14 10:45 __init__.pyo
drwxr-xr-x. 3 root root 4096 Dec  9 12:17 locale
-rw-r--r--. 1 root root  716 Jun  4  2015 version.py
-rw-r--r--. 2 root root  276 Oct 14 10:45 version.pyc
-rw-r--r--. 2 root root  276 Oct 14 10:45 version.pyo
Comment 7 errata-xmlrpc 2015-12-21 12:04:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2676

Note You need to log in before you can comment on or make changes to this bug.