Bug 1271679 - instack should not install unit tests
instack should not install unit tests
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: y2
: 7.0 (Kilo)
Assigned To: Mike Burns
Alexander Chuzhoy
: Triaged
Depends On:
Blocks: 1271670
  Show dependency treegraph
 
Reported: 2015-10-14 09:47 EDT by Mike Burns
Modified: 2015-12-21 11:55 EST (History)
5 users (show)

See Also:
Fixed In Version: instack-0.0.7-2.el7ost
Doc Type: Bug Fix
Doc Text:
Essentially the same text as BZ#1271700. Setting doc_text flag to NACK.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-21 11:55:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Gerrithub.io 249775 None None None Never

  None (edit)
Description Mike Burns 2015-10-14 09:47:55 EDT
instack is currently installing unit tests and those should not be shipped.  This is with the latest OSPd 7.1 package.
Comment 4 Alexander Chuzhoy 2015-11-30 13:02:58 EST
FailedQA:

Environment:
instack-undercloud-2.1.2-34.el7ost.noarch
instack-0.0.7-2.el7ost.noarch

The directory "/usr/lib/python2.7/site-packages/instack_undercloud/tests/" still exists.
Comment 5 Mike Burns 2015-12-03 10:46:05 EST
instack test files were previously stored under:

/usr/lib/python2.7/site-packages/instack/tests which does not exist in the latest version of the instack package

# rpm -qlp instack-0.0.7-2.el7ost.noarch.rpm |grep test
#
Comment 6 Alexander Chuzhoy 2015-12-18 10:28:34 EST
Verified:

Environment:
instack-0.0.7-2.el7ost.noarch


Based on comment #5, verified that /usr/lib/python2.7/site-packages/instack/tests
directory doesn't exist upon deployment.
Comment 8 errata-xmlrpc 2015-12-21 11:55:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2651

Note You need to log in before you can comment on or make changes to this bug.