Bug 1271685 - openstack-tuskar-ui should not install unit tests
openstack-tuskar-ui should not install unit tests
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tuskar-ui (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: y2
: 7.0 (Kilo)
Assigned To: Mike Burns
Ola Pavlenko
: Triaged
Depends On:
Blocks: 1271670
  Show dependency treegraph
 
Reported: 2015-10-14 09:48 EDT by Mike Burns
Modified: 2015-12-21 11:55 EST (History)
5 users (show)

See Also:
Fixed In Version: openstack-tuskar-ui-0.4.0-5.el7ost
Doc Type: Bug Fix
Doc Text:
Essentially the same text as BZ#1271700. Setting doc_text flag to NACK.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-21 11:55:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Gerrithub.io 249784 None None None Never

  None (edit)
Description Mike Burns 2015-10-14 09:48:10 EDT
openstack-tuskar-ui is currently installing unit tests and those should not be shipped.  This is with the latest OSPd 7.1 package.
Comment 4 Ronnie Rasouli 2015-12-06 04:43:59 EST
in 7.0:
ll /usr/lib/python2.7/site-packages/tuskar_ui/*/tests.py*
[stack@instack ~]$ ll /usr/lib/python2.7/site-packages/tuskar_ui/*/tests.py*
-rw-r--r--. 1 root root 11336 Jul 23 07:56 /usr/lib/python2.7/site-packages/tuskar_ui/utils/tests.py
-rw-r--r--. 2 root root 10397 Jul 23 07:56 /usr/lib/python2.7/site-packages/tuskar_ui/utils/tests.pyc
-rw-r--r--. 2 root root 10397 Jul 23 07:56 /usr/lib/python2.7/site-packages/tuskar_ui/utils/tests.pyo
==========================================================================
[stack@instack ~]$ ll /usr/lib/python2.7/site-packages/tuskar_ui/test
total 100
drwxr-xr-x. 2 root root 4096 Dec  3 11:08 api_tests
-rw-r--r--. 1 root root 1818 Apr 17  2015 formset_table_tests.py
-rw-r--r--. 2 root root 2387 Jul 23 07:56 formset_table_tests.pyc
-rw-r--r--. 2 root root 2387 Jul 23 07:56 formset_table_tests.pyo
-rw-r--r--. 1 root root 1599 Apr 17  2015 helpers.py
-rw-r--r--. 2 root root 2137 Jul 23 07:56 helpers.pyc
-rw-r--r--. 2 root root 2137 Jul 23 07:56 helpers.pyo
-rw-r--r--. 1 root root    0 Apr 17  2015 __init__.py
-rw-r--r--. 2 root root  146 Jul 23 07:56 __init__.pyc
-rw-r--r--. 2 root root  146 Jul 23 07:56 __init__.pyo
-rw-r--r--. 1 root root 2091 Apr 17  2015 selenium.py
-rw-r--r--. 2 root root 2151 Jul 23 07:56 selenium.pyc
-rw-r--r--. 2 root root 2151 Jul 23 07:56 selenium.pyo
-rw-r--r--. 1 root root 4367 Apr 17  2015 settings.py
-rw-r--r--. 2 root root 4180 Jul 23 07:56 settings.pyc
-rw-r--r--. 2 root root 4180 Jul 23 07:56 settings.pyo
drwxr-xr-x. 2 root root 4096 Dec  3 11:08 test_data
-rw-r--r--. 1 root root 2405 Apr 17  2015 test_forms.py
-rw-r--r--. 2 root root 2839 Jul 23 07:56 test_forms.pyc
-rw-r--r--. 2 root root 2839 Jul 23 07:56 test_forms.pyo
-rw-r--r--. 1 root root  930 Apr 17  2015 urls.py
-rw-r--r--. 2 root root  590 Jul 23 07:56 urls.pyc
-rw-r--r--. 2 root root  590 Jul 23 07:56 urls.pyo
========================================================
[stack@instack ~]$ ll /usr/lib/python2.7/site-packages/tuskar_ui/utils/tests.py*
-rw-r--r--. 1 root root 11336 Jul 23 07:56 /usr/lib/python2.7/site-packages/tuskar_ui/utils/tests.py
-rw-r--r--. 2 root root 10397 Jul 23 07:56 /usr/lib/python2.7/site-packages/tuskar_ui/utils/tests.pyc
-rw-r--r--. 2 root root 10397 Jul 23 07:56 /usr/lib/python2.7/site-packages/tuskar_ui/utils/tests.pyo
************************************************************
in 7.2 openstack-tuskar-0.4.18-5.el7ost.noarch

[stack@instack ~]$ ll /usr/lib/python2.7/site-packages/tuskar_ui/utils/tests.py*
ls: cannot access /usr/lib/python2.7/site-packages/tuskar_ui/utils/tests.py*: No such file or directory
[stack@instack ~]$ ll /usr/lib/python2.7/site-packages/tuskar_ui/test
ls: cannot access /usr/lib/python2.7/site-packages/tuskar_ui/test: No such file or directory
[stack@instack ~]$ ll /usr/lib/python2.7/site-packages/tuskar_ui/*/tests.py*
ls: cannot access /usr/lib/python2.7/site-packages/tuskar_ui/*/tests.py*: No such file or directory
Comment 6 errata-xmlrpc 2015-12-21 11:55:57 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2651

Note You need to log in before you can comment on or make changes to this bug.