Bug 1271686 - openstack-tuskar-ui-extras should not install unit tests
openstack-tuskar-ui-extras should not install unit tests
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tuskar-ui-extras (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: y2
: 7.0 (Kilo)
Assigned To: Mike Burns
Ola Pavlenko
: Triaged
Depends On:
Blocks: 1271670
  Show dependency treegraph
 
Reported: 2015-10-14 09:48 EDT by Mike Burns
Modified: 2015-12-21 11:56 EST (History)
5 users (show)

See Also:
Fixed In Version: openstack-tuskar-ui-extras-0.0.4-2.el7ost
Doc Type: Bug Fix
Doc Text:
Essentially the same text as BZ#1271700. Setting doc_text flag to NACK.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-21 11:56:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Gerrithub.io 249787 None None None Never

  None (edit)
Description Mike Burns 2015-10-14 09:48:13 EDT
openstack-tuskar-ui-extras is currently installing unit tests and those should not be shipped.  This is with the latest OSPd 7.1 package.
Comment 4 Ronnie Rasouli 2015-12-06 05:14:00 EST
*******************************************
in 7.0


[stack@instack ~]$  ll /usr/lib/python2.7/site-packages/tuskar_sat_ui/nodes/tests.py*
-rw-r--r--. 1 root root 4105 Jun 15 20:44 /usr/lib/python2.7/site-packages/tuskar_sat_ui/nodes/tests.py
-rw-r--r--. 2 root root 3984 Jun 15 21:06 /usr/lib/python2.7/site-packages/tuskar_sat_ui/nodes/tests.pyc
-rw-r--r--. 2 root root 3984 Jun 15 21:06 /usr/lib/python2.7/site-packages/tuskar_sat_ui/nodes/tests.pyo
[stack@instack ~]$ ll /usr/lib/python2.7/site-packages/tuskar_sat_ui/nodes/tests.py*
-rw-r--r--. 1 root root 4105 Jun 15 20:44 /usr/lib/python2.7/site-packages/tuskar_sat_ui/nodes/tests.py
-rw-r--r--. 2 root root 3984 Jun 15 21:06 /usr/lib/python2.7/site-packages/tuskar_sat_ui/nodes/tests.pyc
-rw-r--r--. 2 root root 3984 Jun 15 21:06 /usr/lib/python2.7/site-packages/tuskar_sat_ui/nodes/tests.pyo
[stack@instack ~]$  ll /usr/lib/python2.7/site-packages/tuskar_boxes/overview/tests.py*
-rw-r--r--. 1 root root 4871 Jun 15 20:44 /usr/lib/python2.7/site-packages/tuskar_boxes/overview/tests.py
-rw-r--r--. 2 root root 4462 Jun 15 21:06 /usr/lib/python2.7/site-packages/tuskar_boxes/overview/tests.pyc
-rw-r--r--. 2 root root 4462 Jun 15 21:06 /usr/lib/python2.7/site-packages/tuskar_boxes/overview/tests.pyo
*******************************************************************************
in 7.2 openstack-tuskar-ui-extras-0.0.4-2.el7ost.noarch
[stack@instack ~]$ ll /usr/lib/python2.7/site-packages/tuskar_boxes/static/tuskar_boxes/tests/
ls: cannot access /usr/lib/python2.7/site-packages/tuskar_boxes/static/tuskar_boxes/tests/: No such file or directory
[stack@instack ~]$ ll /usr/lib/python2.7/site-packages/tuskar_boxes/overview/tests.py*
ls: cannot access /usr/lib/python2.7/site-packages/tuskar_boxes/overview/tests.py*: No such file or directory
[stack@instack ~]$ ll /usr/lib/python2.7/site-packages/tuskar_boxes/static/tuskar_boxes/tests/
ls: cannot access /usr/lib/python2.7/site-packages/tuskar_boxes/static/tuskar_boxes/tests/: No such file or directory
[stack@instack ~]$ ll /usr/lib/python2.7/site-packages/tuskar_sat_ui/nodes/tests.py*
ls: cannot access /usr/lib/python2.7/site-packages/tuskar_sat_ui/nodes/tests.py*: No such file or directory
[stack@instack ~]$  ll /usr/lib/python2.7/site-packages/tuskar_boxes/overview/tests.py*
ls: cannot access /usr/lib/python2.7/site-packages/tuskar_boxes/overview/tests.py*: No such file or directory
[stack@instack ~]$  ll /usr/lib/python2.7/site-packages/tuskar_boxes/overview/tests.py*
Comment 6 errata-xmlrpc 2015-12-21 11:56:03 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2651

Note You need to log in before you can comment on or make changes to this bug.