Bug 1271687 - os-apply-config should not install unit tests
os-apply-config should not install unit tests
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: os-apply-config (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: y2
: 7.0 (Kilo)
Assigned To: Mike Burns
Marius Cornea
: Triaged
Depends On:
Blocks: 1271670
  Show dependency treegraph
 
Reported: 2015-10-14 09:48 EDT by Mike Burns
Modified: 2015-12-21 11:56 EST (History)
5 users (show)

See Also:
Fixed In Version: os-apply-config-0.1.31-2.el7ost
Doc Type: Bug Fix
Doc Text:
The os-apply-config tool included unit tests as part of its installation. These tests were meant to be omitted. This fix updates the spec file to remove these tests. Unit test are no longer included with os-apply-config.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-21 11:56:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Gerrithub.io 249792 None None None Never

  None (edit)
Description Mike Burns 2015-10-14 09:48:16 EDT
os-apply-config is currently installing unit tests and those should not be shipped.  This is with the latest OSPd 7.1 package.
Comment 6 Marius Cornea 2015-12-09 15:03:45 EST
stack@instack:~>>> rpm -qa | grep os-apply-config 
os-apply-config-0.1.31-2.el7ost.noarch
stack@instack:~>>> ls -l /usr/lib/python2.7/site-packages/os_apply_config/
total 140
-rw-r--r--. 1 root root 14298 May 11  2015 apply_config.py
-rw-r--r--. 2 root root 13497 Oct 14 11:49 apply_config.pyc
-rw-r--r--. 2 root root 13497 Oct 14 11:49 apply_config.pyo
-rw-r--r--. 1 root root  2437 May 11  2015 collect_config.py
-rw-r--r--. 2 root root  2417 Oct 14 11:49 collect_config.pyc
-rw-r--r--. 2 root root  2417 Oct 14 11:49 collect_config.pyo
-rw-r--r--. 1 root root   655 May 11  2015 config_exception.py
-rw-r--r--. 2 root root   388 Oct 14 11:49 config_exception.pyc
-rw-r--r--. 2 root root   388 Oct 14 11:49 config_exception.pyo
-rw-r--r--. 1 root root     0 May 11  2015 __init__.py
-rw-r--r--. 2 root root   147 Oct 14 11:49 __init__.pyc
-rw-r--r--. 2 root root   147 Oct 14 11:49 __init__.pyo
-rw-r--r--. 1 root root  4246 May 11  2015 oac_file.py
-rw-r--r--. 2 root root  5047 Oct 14 11:49 oac_file.pyc
-rw-r--r--. 2 root root  5047 Oct 14 11:49 oac_file.pyo
-rw-r--r--. 1 root root  1517 May 11  2015 renderers.py
-rw-r--r--. 2 root root  1216 Oct 14 11:49 renderers.pyc
-rw-r--r--. 2 root root  1216 Oct 14 11:49 renderers.pyo
-rw-r--r--. 1 root root  1604 May 11  2015 value_types.py
-rw-r--r--. 2 root root  1207 Oct 14 11:49 value_types.pyc
-rw-r--r--. 2 root root  1207 Oct 14 11:49 value_types.pyo
-rw-r--r--. 1 root root   717 Oct 14 11:49 version.py
-rw-r--r--. 2 root root   272 Oct 14 11:49 version.pyc
-rw-r--r--. 2 root root   272 Oct 14 11:49 version.pyo
Comment 8 errata-xmlrpc 2015-12-21 11:56:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2651

Note You need to log in before you can comment on or make changes to this bug.