Bug 1271688 - os-cloud-config should not install unit tests
os-cloud-config should not install unit tests
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: os-cloud-config (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: y2
: 7.0 (Kilo)
Assigned To: Mike Burns
Marius Cornea
: Triaged
Depends On:
Blocks: 1271670
  Show dependency treegraph
 
Reported: 2015-10-14 09:48 EDT by Mike Burns
Modified: 2015-12-21 11:56 EST (History)
5 users (show)

See Also:
Fixed In Version: os-cloud-config-0.2.8-8.el7ost
Doc Type: Bug Fix
Doc Text:
Essentially the same text as BZ#1271700. Setting doc_text flag to NACK.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-21 11:56:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Gerrithub.io 249794 None None None Never

  None (edit)
Description Mike Burns 2015-10-14 09:48:19 EDT
os-cloud-config is currently installing unit tests and those should not be shipped.  This is with the latest OSPd 7.1 package.
Comment 4 Marius Cornea 2015-12-09 15:04:47 EST
stack@instack:~>>> rpm -qa | grep os-cloud-config 
os-cloud-config-0.2.8-10.el7ost.noarch
stack@instack:~>>> ls -l /usr/lib/python2.7/site-packages/os_collect_config/
total 204
-rw-r--r--. 1 root root  2635 Jun  1  2015 cache.py
-rw-r--r--. 2 root root  2654 Oct 19 19:30 cache.pyc
-rw-r--r--. 2 root root  2654 Oct 19 19:30 cache.pyo
-rw-r--r--. 1 root root  6819 Oct 19 19:30 cfn.py
-rw-r--r--. 2 root root  5381 Oct 19 19:30 cfn.pyc
-rw-r--r--. 2 root root  5381 Oct 19 19:30 cfn.pyo
-rw-r--r--. 1 root root 10702 Jun  1  2015 collect.py
-rw-r--r--. 2 root root  8508 Oct 19 19:30 collect.pyc
-rw-r--r--. 2 root root  8508 Oct 19 19:30 collect.pyo
-rw-r--r--. 1 root root    40 Jun  1  2015 common.py
-rw-r--r--. 2 root root   205 Oct 19 19:30 common.pyc
-rw-r--r--. 2 root root   205 Oct 19 19:30 common.pyo
-rw-r--r--. 1 root root  2078 Jun  1  2015 ec2.py
-rw-r--r--. 2 root root  2093 Oct 19 19:30 ec2.pyc
-rw-r--r--. 2 root root  2093 Oct 19 19:30 ec2.pyo
-rw-r--r--. 1 root root  1854 Jun  1  2015 exc.py
-rw-r--r--. 2 root root  3285 Oct 19 19:30 exc.pyc
-rw-r--r--. 2 root root  3285 Oct 19 19:30 exc.pyo
-rw-r--r--. 1 root root  1935 Oct 19 19:30 heat_local.py
-rw-r--r--. 2 root root  1808 Oct 19 19:30 heat_local.pyc
-rw-r--r--. 2 root root  1808 Oct 19 19:30 heat_local.pyo
-rw-r--r--. 1 root root  3330 Oct 19 19:30 heat.py
-rw-r--r--. 2 root root  2923 Oct 19 19:30 heat.pyc
-rw-r--r--. 2 root root  2923 Oct 19 19:30 heat.pyo
-rw-r--r--. 1 root root     0 Jun  1  2015 __init__.py
-rw-r--r--. 2 root root   149 Oct 19 19:30 __init__.pyc
-rw-r--r--. 2 root root   149 Oct 19 19:30 __init__.pyo
-rw-r--r--. 1 root root  4548 Jun  1  2015 keystone.py
-rw-r--r--. 2 root root  4589 Oct 19 19:30 keystone.pyc
-rw-r--r--. 2 root root  4589 Oct 19 19:30 keystone.pyo
-rw-r--r--. 1 root root  3706 Jun  1  2015 local.py
-rw-r--r--. 2 root root  3338 Oct 19 19:30 local.pyc
-rw-r--r--. 2 root root  3338 Oct 19 19:30 local.pyo
drwxr-xr-x. 3 root root  4096 Dec  9 12:19 openstack
-rw-r--r--. 1 root root  2855 Oct 19 19:30 request.py
-rw-r--r--. 2 root root  2677 Oct 19 19:30 request.pyc
-rw-r--r--. 2 root root  2677 Oct 19 19:30 request.pyo
-rw-r--r--. 1 root root   719 Oct 19 19:30 version.py
-rw-r--r--. 2 root root   276 Oct 19 19:30 version.pyc
-rw-r--r--. 2 root root   276 Oct 19 19:30 version.pyo
Comment 6 errata-xmlrpc 2015-12-21 11:56:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2651

Note You need to log in before you can comment on or make changes to this bug.