Bug 1271700 - os-collect-config should not install unit tests
os-collect-config should not install unit tests
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: os-collect-config (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: y2
: 7.0 (Kilo)
Assigned To: Mike Burns
yeylon@redhat.com
: Triaged
Depends On:
Blocks: 1271670
  Show dependency treegraph
 
Reported: 2015-10-14 09:57 EDT by Mike Burns
Modified: 2016-04-18 03:06 EDT (History)
10 users (show)

See Also:
Fixed In Version: os-collect-config-0.1.35-3.el7ost
Doc Type: Bug Fix
Doc Text:
The base RPMs included unit tests. This meant the director had unnecessary files that consumed extra space. This fix removes the tests from the base RPMs. Unit tests are now only shipped with the source RPMs.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-21 11:56:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Gerrithub.io 149767 None None None Never

  None (edit)
Description Mike Burns 2015-10-14 09:57:26 EDT
os-collect-config is currently installing unit tests and those should not be shipped.  This is with the latest OSPd 7.1 package.
Comment 4 Dan Yasny 2015-10-22 14:09:10 EDT
Checked that the tests directory /usr/lib/python2.7/site-packages/os_collect_config/tests is missing in the new RPM os-collect-config-0.1.35-5.el7ost.noarch

rpm -ql os-collect-config-0.1.35-5.el7ost.noarch |grep tests 

returns empty
Comment 5 Dan Yasny 2015-10-22 14:31:17 EDT
verified in os-collect-config-0.1.35-5.el7ost.noarch
Comment 8 errata-xmlrpc 2015-12-21 11:56:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2651

Note You need to log in before you can comment on or make changes to this bug.