Bug 1271707 - RHEV-H upgrade from 3.5.4 to 3.5.5 failed, because vdsm not stopped
RHEV-H upgrade from 3.5.4 to 3.5.5 failed, because vdsm not stopped
Status: CLOSED DUPLICATE of bug 1254196
Product: vdsm
Classification: oVirt
Component: Tools (Show other bugs)
4.16.26
All Linux
medium Severity urgent (vote)
: ovirt-3.5.6
: ---
Assigned To: Yaniv Bronhaim
Aharon Canan
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-14 10:11 EDT by Artyom
Modified: 2016-02-10 14:18 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-15 08:19:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
gklein: ovirt‑3.5.z?
gklein: blocker?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
sos report (6.17 MB, application/x-xz)
2015-10-14 10:12 EDT, Artyom
no flags Details

  None (edit)
Description Artyom 2015-10-14 10:11:21 EDT
Description of problem:
RHEV-H upgrade from 3.5.4 to 3.5.5 failed, because vdsm not stopped

Version-Release number of selected component (if applicable):
From:
Red Hat Enterprise Virtualization Hypervisor release 7.1 (20150911.0.el7ev)
ovirt-hosted-engine-ha-1.2.6-3.el7ev.noarch
ovirt-node-plugin-hosted-engine-0.2.0-18.0.el7ev.noarch
ovirt-hosted-engine-setup-1.2.5.3-1.el7ev.noarch
vdsm-4.16.26-1.el7ev.x86_64
To:
rhev-hypervisor7-7.1-20151013.0.el7ev

How reproducible:
Always

Steps to Reproduce:
1. Install rhev-hypervisor7-7.1-20150911.0.el7ev(https://brewweb.devel.redhat.com/buildinfo?buildID=456370) on two hosts
2. Deploy hosted-engine on both environments(not sure if it connect)
3. Put host without engine vm to maintenance, and try to upgrade host to rhev-hypervisor7-7.1-20151013.0.el7ev(https://brewweb.devel.redhat.com/buildinfo?buildID=460832)

Actual results:
Upgrade fail with error message under ovirt-node-upgrade.log
2015-10-14 07:42:39,705 - DEBUG    - ovirt-node-upgrade - Failed to stop vdsdm: Error:  ServiceOperationError: _systemctlStop failed
Job for vdsmd.service canceled.



2015-10-14 07:42:39,705 - ERROR    - ovirt-node-upgrade - Error: Upgrade Failed: Command Failed: '('/usr/libexec/ovirt-node/hooks/pre-upgrade/01-vdsm',)' [u'/usr/libexec/ovirt-node/hooks/pre-upgrade/01-vdsm: Stopping vdsmd to upgrade']
Traceback (most recent call last):
  File "/usr/sbin/ovirt-node-upgrade", line 365, in run
    self._run_hooks("pre-upgrade")
  File "/usr/sbin/ovirt-node-upgrade", line 197, in _run_hooks
    self._system(hook)
  File "/usr/sbin/ovirt-node-upgrade", line 145, in _system
    raise RuntimeError("Command Failed: '%s' %s" % (command, output))
RuntimeError: Command Failed: '('/usr/libexec/ovirt-node/hooks/pre-upgrade/01-vdsm',)' [u'/usr/libexec/ovirt-node/hooks/pre-upgrade/01-vdsm: Stopping vdsmd to upgrade']


Expected results:
Upgrade succeed

Additional info:
The same problem exist in RHEV-H 6.7
Comment 1 Artyom 2015-10-14 10:12 EDT
Created attachment 1082837 [details]
sos report
Comment 2 Artyom 2015-10-14 12:44:38 EDT
Some additional information:
1) Upgrade via USB and not via engine succeed in HE environment
2) Upgrade via engine works for not HE environment
Comment 4 Anatoly Litovsky 2015-10-15 08:19:35 EDT

*** This bug has been marked as a duplicate of bug 1254196 ***

Note You need to log in before you can comment on or make changes to this bug.