Bug 1271766 - IOError: [Errno 2] No such file or directory: '/mnt/sysimage/etc/yum/pluginconf.d/langpacks.conf'
Summary: IOError: [Errno 2] No such file or directory: '/mnt/sysimage/etc/yum/pluginco...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 7.2
Hardware: x86_64
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Brian Lane
QA Contact: Release Test Team
Petr Bokoc
URL:
Whiteboard: abrt_hash:122310ef7d0da9aaf9e87942f5b...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-14 15:58 UTC by Alexander Todorov
Modified: 2017-01-11 15:19 UTC (History)
4 users (show)

Fixed In Version: anaconda-21.48.22.57-1
Doc Type: Bug Fix
Doc Text:
Installation no longer fails when using "%packages --nobase --nocore" in a Kickstart file Previously, using a Kickstart file which contained the "%packages" section and specified the "--nobase" and "--nocore" options at the same time caused the installation to fail with a traceback message due to a missing _yum-langpacks_ package. The package is now available, and the described problem no longer occurs.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 23:18:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (323.61 KB, text/plain)
2015-10-14 15:58 UTC, Alexander Todorov
no flags Details
File: anaconda.log (16.00 KB, text/plain)
2015-10-14 15:58 UTC, Alexander Todorov
no flags Details
File: environ (492 bytes, text/plain)
2015-10-14 15:58 UTC, Alexander Todorov
no flags Details
File: ks.cfg (340 bytes, text/plain)
2015-10-14 15:58 UTC, Alexander Todorov
no flags Details
File: lsblk_output (1.67 KB, text/plain)
2015-10-14 15:58 UTC, Alexander Todorov
no flags Details
File: nmcli_dev_list (1.21 KB, text/plain)
2015-10-14 15:58 UTC, Alexander Todorov
no flags Details
File: os_info (522 bytes, text/plain)
2015-10-14 15:58 UTC, Alexander Todorov
no flags Details
File: program.log (31.87 KB, text/plain)
2015-10-14 15:58 UTC, Alexander Todorov
no flags Details
File: storage.log (78.60 KB, text/plain)
2015-10-14 15:58 UTC, Alexander Todorov
no flags Details
File: syslog (71.61 KB, text/plain)
2015-10-14 15:58 UTC, Alexander Todorov
no flags Details
File: ifcfg.log (2.94 KB, text/plain)
2015-10-14 15:58 UTC, Alexander Todorov
no flags Details
File: packaging.log (42.17 KB, text/plain)
2015-10-14 15:58 UTC, Alexander Todorov
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2158 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2016-11-03 13:13:55 UTC

Description Alexander Todorov 2015-10-14 15:58:42 UTC
Version-Release number of selected component:
anaconda-21.48.22.55-1

The following was filed automatically by anaconda:
anaconda 21.48.22.55-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/shutil.py", line 83, in copyfile
    with open(dst, 'wb') as fdst:
  File "/usr/lib64/python2.7/shutil.py", line 130, in copy2
    copyfile(src, dst)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 267, in _copyLangpacksConfigToTarget
    iutil.getSysroot()+_yum_target_langpack_conf)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1563, in postInstall
    self._copyLangpacksConfigToTarget()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 257, in doInstall
    payload.postInstall()
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run
    threading.Thread.run(self, *args, **kwargs)
IOError: [Errno 2] No such file or directory: '/mnt/sysimage/etc/yum/pluginconf.d/langpacks.conf'

Additional info:
addons:         org_fedora_oscap, com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   inst.repo=http://download.eng.bos.redhat.com/nightly/RHEL-7.2-20151013.n.0/compose/Server/x86_64/os  ks=http://192.168.122.1/ks.cfg
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.10.0-323.el7.x86_64
product:        Red Hat Enterprise Linux 7
release:        Red Hat Enterprise Linux Workstation release 7.2 Beta (Maipo)
release_type:   pre-release
type:           anaconda
uid:            0
version:        7.2

Potential duplicate: bug 1172004

Comment 1 Alexander Todorov 2015-10-14 15:58:44 UTC
Created attachment 1082885 [details]
File: anaconda-tb

Comment 2 Alexander Todorov 2015-10-14 15:58:45 UTC
Created attachment 1082886 [details]
File: anaconda.log

Comment 3 Alexander Todorov 2015-10-14 15:58:46 UTC
Created attachment 1082887 [details]
File: environ

Comment 4 Alexander Todorov 2015-10-14 15:58:47 UTC
Created attachment 1082888 [details]
File: ks.cfg

Comment 5 Alexander Todorov 2015-10-14 15:58:48 UTC
Created attachment 1082889 [details]
File: lsblk_output

Comment 6 Alexander Todorov 2015-10-14 15:58:49 UTC
Created attachment 1082890 [details]
File: nmcli_dev_list

Comment 7 Alexander Todorov 2015-10-14 15:58:50 UTC
Created attachment 1082891 [details]
File: os_info

Comment 8 Alexander Todorov 2015-10-14 15:58:52 UTC
Created attachment 1082892 [details]
File: program.log

Comment 9 Alexander Todorov 2015-10-14 15:58:53 UTC
Created attachment 1082893 [details]
File: storage.log

Comment 10 Alexander Todorov 2015-10-14 15:58:55 UTC
Created attachment 1082894 [details]
File: syslog

Comment 11 Alexander Todorov 2015-10-14 15:58:56 UTC
Created attachment 1082895 [details]
File: ifcfg.log

Comment 12 Alexander Todorov 2015-10-14 15:58:57 UTC
Created attachment 1082896 [details]
File: packaging.log

Comment 13 Alexander Todorov 2015-10-14 16:00:38 UTC
Testing with the ks.cfg from:
https://bugzilla.redhat.com/show_bug.cgi?id=1190764#c2

At the end of the installation I hit this error. IIRC there was a similar error in RHEL 6 but can't find the bug right now.

Comment 15 David Cantrell 2015-10-14 18:39:10 UTC
Using the kickstart file from bug #1190764, can you add "yum-langpacks" to the %packages section and see if it works?  I think this is a bug from the rebase of anaconda, but one that we can work around for 7.2.

Comment 16 Alexander Todorov 2015-10-15 08:07:52 UTC
(In reply to David Cantrell from comment #15)
> Using the kickstart file from bug #1190764, can you add "yum-langpacks" to
> the %packages section and see if it works?  I think this is a bug from the
> rebase of anaconda, but one that we can work around for 7.2.

Adding yum-langpacks works.

Comment 17 David Cantrell 2015-10-15 12:13:43 UTC
Documenting as a known issue with workaround for 7.2, moving to the 7.3 planning list.  Thanks, Alexander.

Comment 20 Michal Kovarik 2016-08-05 12:45:58 UTC
Verified on anaconda-21.48.22.81-1. System is installed successfully with:
%packages --instLangs=bg_BG --nocore --nobase
httpd
%end

Comment 22 errata-xmlrpc 2016-11-03 23:18:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2158.html


Note You need to log in before you can comment on or make changes to this bug.