Bug 1271772 - vdsm reports that the storage domain is active, when in fact it's missing a link to it
vdsm reports that the storage domain is active, when in fact it's missing a l...
Status: CLOSED DUPLICATE of bug 1271771
Product: vdsm
Classification: oVirt
Component: General (Show other bugs)
4.17.8
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-3.6.0-rc3
: 4.17.8
Assigned To: Dan Kenigsberg
Aharon Canan
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-14 12:24 EDT by Natalie Gavrielov
Modified: 2016-02-10 12:46 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-15 02:52:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
ngavrilo: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
vdsm.log, engine.log (2.38 MB, application/x-gzip)
2015-10-14 12:24 EDT, Natalie Gavrielov
no flags Details

  None (edit)
Description Natalie Gavrielov 2015-10-14 12:24:38 EDT
Created attachment 1082900 [details]
vdsm.log, engine.log

Description of problem:

When blocking a connection between hosts and the current master storage domain, later on reviving it, storage domain is reported as active,
when in fact, a link is missing under /rhev/data-center/SPUUID.


How reproducible:
100

Steps to Reproduce:

1. Block a connection between hosts and the current master storage domain.
2. Reviving the connection (undo blocking).
3. Create a disk using this storage domain.

Actual results:

Getting the following error:
(engine.log)
2015-10-14 16:50:50,861 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (org.ovirt.thread.pool-7-thread-46) [] Correlation ID: d125544, Job ID: 2acf9172-88da-4277-92f8-39772ae968f1, Call Stack: null, Custom Event ID: -1, Message: Add-Disk operation failed to complete.

vdsm.log:
Thread-92::ERROR::2015-10-14 16:50:28,302::sdc::138::Storage.StorageDomainCache::(_findDomain) looking for unfetched domain 01a00df6-34fb-4cad-bf1b-11b1faff1748
Thread-92::ERROR::2015-10-14 16:50:28,302::sdc::155::Storage.StorageDomainCache::(_findUnfetchedDomain) looking for domain 01a00df6-34fb-4cad-bf1b-11b1faff1748

Also, states here that the storage domain is active:
Thread-85::INFO::2015-10-14 16:30:21,379::logUtils::48::dispatcher::(wrapper) Run and protect: connectStoragePool(spUUID=u'00000001-0001-0001-0001-000000000301', hostID=1, msdUUID=u'6e141ccd-ab7f-4d3d-a0d8-d3b4356
6cfc5', masterVersion=3, domainsMap={u'01a00df6-34fb-4cad-bf1b-11b1faff1748': u'active', u'34c84bc0-e13f-414c-97e3-5dab9532b799': u'attached', u'6e141ccd-ab7f-4d3d-a0d8-d3b43566cfc5': u'active', u'78a4a497-4dd7-4c
f5-b7a8-264a8d467f05': u'active'}, options=None)


Expected results:

1. VDSM should be able to activate the storage domain.   
2. Create disk will succeed. 


vdsm version: vdsm-4.17.8-1.el7ev.noarch

Seems it is the same issue that was found here:
https://bugzilla.redhat.com/show_bug.cgi?id=1026697


Additional info:
vdsm.log, engine.log
Comment 1 Dan Kenigsberg 2015-10-15 02:52:24 EDT

*** This bug has been marked as a duplicate of bug 1271771 ***

Note You need to log in before you can comment on or make changes to this bug.