Bug 1271778 - ipsec whack man page discrepancies
ipsec whack man page discrepancies
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libreswan (Show other bugs)
6.7
All Linux
medium Severity medium
: rc
: ---
Assigned To: Paul Wouters
Jaroslav Aster
:
Depends On:
Blocks: 1272112
  Show dependency treegraph
 
Reported: 2015-10-14 12:44 EDT by Ondrej Moriš
Modified: 2016-04-29 10:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1272112 (view as bug list)
Environment:
Last Closed: 2015-12-15 08:24:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:2628 normal SHIPPED_LIVE new packages: libreswan 2015-12-15 13:20:08 EST

  None (edit)
Description Ondrej Moriš 2015-10-14 12:44:54 EDT
Description of problem:

Man page ipsec_whack is missing and man ipsec whack points to ipsec(8) instead of ipsec_pluto(8).

Version-Release number of selected component (if applicable):

libreswan-3.15-4.el6

How reproducible:

100%

Steps to Reproduce:
1. man ipsec_whack
2. man ipsec whack

Actual results:

1. No manual entry for ipsec_whack
2. IPSEC(8)

Expected results:

1. IPSEC_PLUTO(8)
2. IPSEC_PLUTO(8)

Additional info:

N/A
Comment 1 Paul Wouters 2015-10-14 13:25:12 EDT
diff --git a/programs/pluto/ipsec_pluto.8.xml b/programs/pluto/ipsec_pluto.8.xml
index 1e15144..3c823dc 100644
--- a/programs/pluto/ipsec_pluto.8.xml
+++ b/programs/pluto/ipsec_pluto.8.xml
@@ -18,6 +18,7 @@
 
   <refnamediv id="name">
     <refname>ipsec pluto</refname>
+    <refname>ipsec whack</refname>
     <refname>pluto</refname>
 
     <refpurpose>ipsec whack : IPsec IKE keying daemon and control interface</refpurpose>
Comment 3 Ondrej Moriš 2015-12-03 04:51:08 EST
(In reply to Ondrej Moriš from comment #0)

> Steps to Reproduce:
> 1. man ipsec_whack

Verified. 

# rpm -q libreswan
libreswan-3.15-5.el6.x86_64
# man ipsec_whack | head -1
IPSEC_PLUTO(8)                Executable programs               IPSEC_PLUTO(8)

> 2. man ipsec whack

Apparently one cannot reference manual page witch space on rhel6. Thus step 2 is invalid, 'mak ipsec whack' is equivalent to calling 'man ipsec; man whack'.
Comment 5 errata-xmlrpc 2015-12-15 08:24:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2628.html

Note You need to log in before you can comment on or make changes to this bug.