This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1271812 - iscsi target broken in 4.2.2 kernel
iscsi target broken in 4.2.2 kernel
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-14 15:27 EDT by Andy Grover
Modified: 2015-11-04 14:34 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-04 01:05:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Grover 2015-10-14 15:27:25 EDT
4.2.x kernels, x=2 currently, do not have:

iscsi-target: Avoid OFMarker + IFMarker negotiation

673681cafa 

which I've submitted to stable on Oct 2 but hasn't made it in yet. Otherwise, LIO is broken when used with the MS iscsi initiator.

Please apply this fix to Fedora kernels, hopefully it will show up in -stable soon as well.
Comment 1 Andy Grover 2015-10-14 15:31:08 EDT
actually x=3 but still, it's not in there.
Comment 2 Josh Boyer 2015-11-02 15:39:15 EST
This was added with the 4.2.4/4.2.5 kernels with

commit b457470c65a41938a1b6be511020e9c7945886be
Author: Justin M. Forbes <jforbes@redhat.com>
Date:   Thu Oct 15 09:44:35 2015 -0500

    Fix for iscsi target issues (#rhbz 1271812)
Comment 3 Chris Egolf 2015-11-02 16:54:54 EST
I installed kernel-4.2.5-201.fc22.x86_64 as suggested from updates-testing and I still get the following errors:

Nov 02 14:52:36 cartman systemd[1]: iscsid.service stopping timed out. Terminating.
Nov 02 14:52:36 cartman systemd[1]: Unit iscsid.service entered failed state.
Nov 02 14:52:36 cartman audit[1]: <audit-1131> pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=iscsid comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
Nov 02 14:52:36 cartman systemd[1]: iscsid.service failed.
Nov 02 14:52:36 cartman systemd[1]: Starting Open-iSCSI...
Nov 02 14:52:36 cartman iscsid[3229]: iSCSI logger with pid=3231 started!
Nov 02 14:52:36 cartman systemd[1]: Started Open-iSCSI.
Nov 02 14:52:36 cartman audit[1]: <audit-1130> pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=iscsid comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Nov 02 14:45:05 cartman iscsid[2881]: iSCSI daemon with pid=2882 started!
Nov 02 14:45:05 cartman iscsid[2881]: IPC qtask write failed: Broken pipe
Nov 02 14:45:05 cartman iscsid[2881]: iscsid shutting down.


This works with kernel 4.1.10-200.fc22.x86_64.
Comment 4 Andy Grover 2015-11-02 19:19:00 EST
(In reply to Chris Egolf from comment #3)
> I installed kernel-4.2.5-201.fc22.x86_64 as suggested from updates-testing
> and I still get the following errors:

iscsid is not involved with the issue in this BZ, please open a new BZ against iscsi-initiator?
Comment 5 Chris Egolf 2015-11-04 00:45:55 EST
(In reply to Andy Grover from comment #4)
> iscsid is not involved with the issue in this BZ, please open a new BZ
> against iscsi-initiator?

Fedora 23 with the 4.2.3-300.fc23 kernel resolved the issue on several systems for me.
Comment 6 Andy Grover 2015-11-04 01:05:44 EST
Great thanks! Closing.
Comment 7 Josh Boyer 2015-11-04 10:20:37 EST
*** Bug 1273252 has been marked as a duplicate of this bug. ***
Comment 8 Torbjorn Jansson 2015-11-04 12:42:35 EST
Does this mean you don't intend to fix this issue for fc22?
Comment 9 Justin M. Forbes 2015-11-04 13:16:33 EST
No, it means this particular issue was fixed in F22 with the 4.2.5 kernel.
Comment 10 Torbjorn Jansson 2015-11-04 13:36:44 EST
ok, got it.
just got a bit confused because in Bug 1273252 that was closed as a dupe there was a report that 4.2.5 kernel in testing did not fix the issue.
Comment 11 Justin M. Forbes 2015-11-04 14:34:47 EST
There should be no differences in the kernel as far as iscsi is concerned for F22 and F23. F23 does have an updated iscsi-initiator-utils which may be required for recent kernels.

Note You need to log in before you can comment on or make changes to this bug.