Bug 1271823 - freecol crashes at start up
freecol crashes at start up
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: freecol (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
AcceptedFreezeException
:
Depends On:
Blocks: F23FinalFreezeException
  Show dependency treegraph
 
Reported: 2015-10-14 15:50 EDT by Bruno Wolff III
Modified: 2015-10-19 17:07 EDT (History)
4 users (show)

See Also:
Fixed In Version: freecol-0.11.6-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-19 17:07:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2015-10-14 15:50:51 EDT
Description of problem:
[liveuser@localhost ~]$ freecol
Java virtual machine used: /usr/lib/jvm/jre-openjdk/bin/java
classpath used: /usr/share/java/freecol.jar:/usr/share/java/commons-cli.jar:/usr/share/java/cortado.jar:/usr/share/java/jogg.jar:/usr/share/java/jorbis.jar:/usr/share/java/miglayout-core.jar:/usr/share/java/miglayout-swing.jar
main class used: net.sf.freecol.FreeCol
flags used: 
options used: '-Xmx512M' '-Xincgc' '-Dsun.java2d.pmoffscreen=false'
arguments used: --freecol-data /usr/share/freecol/data
OpenJDK Server VM warning: Using incremental CMS is deprecated and will likely be removed in a future release
Exception in thread "main" java.lang.ClassCastException: java.io.File cannot be cast to java.lang.Class
	at org.apache.commons.cli.OptionBuilder.withType(OptionBuilder.java:298)
	at net.sf.freecol.FreeCol.handleArgs(FreeCol.java:556)
	at net.sf.freecol.FreeCol.main(FreeCol.java:239)
[liveuser@localhost ~]$ 

Version-Release number of selected component (if applicable):
freecol-0.11.5-1.fc23.noarch

How reproducible:
Seems to happen every time.
Comment 1 Bruno Wolff III 2015-10-14 16:04:56 EDT
If this gets fixed soon, I'll ask for a freeze exception so that the games spin has a working version.
Comment 2 Bruno Wolff III 2015-10-15 01:24:28 EDT
This bug was reported to Debian (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=798699). They claim it is fixed in th latest release, but that is what we are running. Maybe one of our patches is causing a problem.
Comment 3 Hans de Goede 2015-10-17 09:39:37 EDT
Hi,

Thanks for the bug-report. 0.11.6 was just released, I've tried updating to this, but that did not help either, so I've ended up forward porting Debian's patch to 0.11.6 (Debian is still at 0.10.7).

A new 0.11.6 package which includes the fix for this is on its way. I'm fine with requesting a freeze exception since the current package is completely unusable we cannot make matters worse in any way.

Regards,

Hans
Comment 4 Fedora Update System 2015-10-17 09:52:42 EDT
freecol-0.11.6-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-fd139300f2
Comment 5 Fedora Update System 2015-10-17 14:20:55 EDT
freecol-0.11.6-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update freecol'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-fd139300f2
Comment 6 Bruno Wolff III 2015-10-17 19:01:57 EDT
0.11.6-1.fc23 works for me. Thanks.
Comment 7 Bruno Wolff III 2015-10-17 19:07:52 EDT
A freeze exception is requested for freecol because it is completely broken for the games spin. The games spin is really meant to be used live so updates aren't ideal. I doubt that freecol is used for any other deliverable, so it's unlikely to break anything we would block on. freecol is not one of the 9 featured games so it isn't a disaster if it isn't working. But it would seem that it would be very low risk to take an update for.
Comment 8 Kalev Lember 2015-10-18 08:37:11 EDT
(In reply to Bruno Wolff III from comment #6)
> 0.11.6-1.fc23 works for me. Thanks.

Can you +1 the update in bodhi as well if it works for you, please?
Comment 9 Adam Williamson 2015-10-19 16:04:03 EDT
Discussed at 2015-10-19 freeze exception review meeting: https://meetbot.fedoraproject.org/fedora-blocker-review/2015-10-19/f23-blocker-review.2015-10-19-16.00.html . Accepted as a freeze exception issue: obviously it's good for the packages shipped on the frozen Games DVD to work, and this fix can't break anything else as the package isn't shipped on anything else.
Comment 10 Fedora Update System 2015-10-19 17:07:54 EDT
freecol-0.11.6-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.