Bug 1271853 - Some users experience slowness in Satellite WebUI when browsing servers while others are normal.
Some users experience slowness in Satellite WebUI when browsing servers while...
Status: CLOSED DEFERRED
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
570
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Grant Gainey
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-14 17:34 EDT by Paul Wayper
Modified: 2017-06-08 11:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-08 11:32:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Wayper 2015-10-14 17:34:50 EDT
Description of problem:

In Satellite, some users experience slowness in the WebUI when browsing systems, while other users experience no slowdown.  Usually the Admin user is unaffected.  Typical results are taking two minutes for the Systems page to load for an affected user but two seconds for Admin to view the same page.

Version-Release number of selected component (if applicable):

5.7

How reproducible:

Unsure.  It seems to be related to how many records the user has in the rhnuserserverperms table, but not always.

My best guess at how to reproduce this problem are:

1. Create several users that view different systems.
2. Add a large number of systems.
3. At this point I believe there should be a large number of records in the rhnuserserverperms table for that user, probably corresponding to one record for each system.
4. View the Systems page as one of those users.

Actual results:

Slow interface compared to Admin user.

Expected results:

The same speed compared to Admin user.
Comment 1 Tomas Lestach 2017-06-08 11:32:17 EDT
We have re-reviewed this bug, as part of an ongoing effort to improve Satellite/Proxy feature and bug updates, review and backlog.

This is a low priority bug and has no currently open customer cases. While this bug may still valid, we do not see it being implemented prior to the EOL of the Satellite 5.x product. As such, this is being CLOSED DEFERRED. 

Closing now to help set customer expectations as early as possible. You are welcome to re-open this bug if needed.

Note You need to log in before you can comment on or make changes to this bug.