Bug 1271904 - TaskEventListener is not working as expected with "Per-Process-Instance and per-request" runtime strategies
TaskEventListener is not working as expected with "Per-Process-Instance and p...
Status: CLOSED DUPLICATE of bug 1206506
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Core (Show other bugs)
6.1.0
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Maciej Swiderski
Radovan Synek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-15 00:28 EDT by Abhijit humbe
Modified: 2015-11-02 19:44 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-16 11:03:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
abhumbe: needinfo-


Attachments (Terms of Use)
reproducer (6.35 KB, application/zip)
2015-10-15 00:28 EDT, Abhijit humbe
no flags Details

  None (edit)
Description Abhijit humbe 2015-10-15 00:28:12 EDT
Created attachment 1083131 [details]
reproducer

Description of problem:
Custom task event listener firing only for "afterTaskAddedEvent" but not any of the task update events like afterTaskActivatedEvent/afterTaskClaimedEvent/afterTaskStartedEvent  if we use "Per-Process-Instance/per-request"  runtime strategies while deploying kjar. Its working fine with singleton runtime strategies. 

Version-Release number of selected component (if applicable):


How reproducible:
With Per-Process-Instance/per-request runtime strategies

Steps to Reproduce:
1.Create custom TaskEventListener register it using kie-deployment-descriptor.xml
2. Deploy kjar with Per-Process-Instance/per-request runtime strategies
3. Start process instance and and check output

Actual results:
TaskEventListener not working as expected with Per-Process-Instance and per-request  runtime strategies

Expected results:
TaskEventListener should work with all runtime strategies

Additional info:
Output of attached reproducer:

With singleton runtime strategies
=================================
INFO  [stdout] (http-127.0.0.1:8080-4) **beforeTaskAddedEvent**
INFO  [stdout] (http-127.0.0.1:8080-4) **afterTaskAddedEvent**
INFO  [stdout] (http-127.0.0.1:8080-1) **beforeTaskStartedEvent**
INFO  [stdout] (http-127.0.0.1:8080-1) **beforeTaskCompletedEvent**
INFO  [stdout] (http-127.0.0.1:8080-1) **afterTaskCompletedEvent**


With per-Process-Instance runtime strategies
===============================
INFO  [stdout] (http-127.0.0.1:8080-4) **beforeTaskAddedEvent**
INFO  [stdout] (http-127.0.0.1:8080-4) **afterTaskAddedEvent**
Comment 2 Maciej Swiderski 2015-10-15 10:09:47 EDT
this is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1206506 that is already fixed in 6.3.x and master

shall we then close it?
Comment 3 Kris Verlaenen 2015-10-16 11:03:52 EDT

*** This bug has been marked as a duplicate of bug 1206506 ***

Note You need to log in before you can comment on or make changes to this bug.