Bug 1271906 - RFE : gdal additional executables : 8211dump , 8211view , s57dump
RFE : gdal additional executables : 8211dump , 8211view , s57dump
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gdal (Show other bugs)
22
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Devrim GÜNDÜZ
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-15 01:09 EDT by Ken
Modified: 2015-11-12 21:52 EST (History)
9 users (show)

See Also:
Fixed In Version: gdal-2.0.1-2.fc23 gdal-1.11.3-1.fc22 gdal-1.11.3-1.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-12 18:29:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ken 2015-10-15 01:09:35 EDT
Description of problem:

It would be nice to build a few more executeables that are in the gdal.org source (maybe make a new package: "gdal-utils" ?)

In the directory frmts/iso8211, there is 8211dump , 8211view

... and in the directory ogr/ogrsf_frmts/s57 , there is s57dump

FYI, the reason I noticed it is that in the "OpenSeaMap" project, they use the output of "8211view" to create a OpenStreetMap format XML file.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Volker Fröhlich 2015-10-17 20:57:15 EDT
https://trac.osgeo.org/gdal/ticket/6159#ticket

With this out of the way, I see no technical problems in doing what you are asking for. I'll think about possible sub-packaging. Technically speaking, it's not necessary, because the binaries introduce no dependencies and are only a few kB.
Comment 2 Fedora Update System 2015-10-22 03:37:29 EDT
gdal-1.11.3-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-1bc0d03a5f
Comment 3 Fedora Update System 2015-10-22 03:37:33 EDT
gdal-1.11.3-1.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-c372c61eb7
Comment 4 Fedora Update System 2015-10-22 03:37:44 EDT
gdal-2.0.1-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-4954ad5b15
Comment 5 Fedora Update System 2015-10-24 08:08:08 EDT
gdal-2.0.1-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update gdal'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-4954ad5b15
Comment 6 Fedora Update System 2015-10-26 06:27:34 EDT
gdal-1.11.3-1.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update gdal'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-c372c61eb7
Comment 7 Fedora Update System 2015-10-26 14:29:30 EDT
gdal-1.11.3-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update gdal'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-1bc0d03a5f
Comment 8 Fedora Update System 2015-11-12 18:29:32 EST
gdal-2.0.1-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2015-11-12 20:53:02 EST
gdal-1.11.3-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2015-11-12 21:52:06 EST
gdal-1.11.3-1.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.