Bug 1271941 - Warning Cinder scheduler context
Warning Cinder scheduler context
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
5.0 (RHEL 7)
Unspecified Unspecified
medium Severity medium
: ---
: 8.0 (Liberty)
Assigned To: Eric Harney
nlevinki
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-15 02:38 EDT by Shinobu KINJO
Modified: 2016-08-30 10:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-19 02:42:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shinobu KINJO 2015-10-15 02:38:26 EDT
Description of problem:

A bunch of noisy messages from cinder coming from:


    /usr/lib/python2.7/site-packages/cinder/context.py


Message is:


    "opme1os205 <148>Oct 12 15:45:57 opme1os205 journal: cinder-scheduler
    2015-10-12 15:45:57.192 53795 WARNING cinder.context [-] Arguments 
    dropped when creating context: {'user': None, 'tenant': None, 'user_identity': u'- - - - -'}"


This is because of:


    62         if kwargs:
    63             LOG.warn(_('Arguments dropped when creating context: %s') %
    64                      str(kwargs))


Especially:


    kwargs


Based on explanation in context.py, this param is not
necessary here.


   59         :param kwargs: Extra arguments that might be present, but we ignore
   60             because they possibly came in from older rpc messages.


Question from my side,


   Why do we still keep that __if__ block?

   
I think that there is no dependencies with that block.
So we should be able to simply remove those 3 lines.

What do you think?

If I've missed anything, point it out to me.

Shinobu
    
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Sergey Gotliv 2015-10-19 02:42:18 EDT
Cinder stopped printing these messages in Juno (6.0).
Comment 5 Shinobu KINJO 2016-04-04 20:03:13 EDT
(In reply to Sergey Gotliv from comment #2)
> Cinder stopped printing these messages in Juno (6.0).

Will this fix be (able to be) backported to Icehouse based OSP?

Note You need to log in before you can comment on or make changes to this bug.