Bug 127200 - Wrong Qt path in dbus.spec file
Wrong Qt path in dbus.spec file
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dbus (Show other bugs)
2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-03 15:55 EDT by Dawid Gajownik
Modified: 2013-03-13 00:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-25 14:29:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dawid Gajownik 2004-07-03 15:55:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.7) Gecko/20040616

Description of problem:
In dbus.spec file there are these lines:

if test -d %{_libdir}/qt-3.1 ; then
   export QTDIR=%{_libdir}/qt-3.1
else
   echo "WARNING: %{_libdir}/qt-3.1 does not exist"
fi

It should be changed to %{_libdir}/qt-3.3. The same bug appears in
rawhide package.

Maybe it is not a big problem, because qt package is disabled by
default (I'm curious why? I skimmed through the changelog and there is
nothing special.) but it would be nice to have everything correct :)

Version-Release number of selected component (if applicable):
dbus-0.20-4.1

How reproducible:
Always

Steps to Reproduce:
1. open dbus.spec file
Comment 1 John (J5) Palmieri 2004-08-25 14:29:28 EDT
Closing notabug.  We don't use the Qt bindings as they are yet to be
completed.  If you wish to include a patch that uses a version
variable to track the correct version of Qt (and detect if it is
installed) I will be happy to add it.
Comment 2 Dawid Gajownik 2004-08-30 04:18:23 EDT
I'm rather a newbie and I may be wrong, but why not use QTDIR variable
set by /etc/profile.d/qt.sh file from qt-devel? I presume that
qt-devel would be also needed to compile Qt bindings :I

Note You need to log in before you can comment on or make changes to this bug.