Bug 1272007 - tools/glusterfind: add query command to list files without session
tools/glusterfind: add query command to list files without session
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterfind (Show other bugs)
3.7.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milind Changire
bugs@gluster.org
:
Depends On: 1272006 1272008
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-15 05:24 EDT by Milind Changire
Modified: 2016-04-19 03:47 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1272006
Environment:
Last Closed: 2016-02-15 01:55:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milind Changire 2015-10-15 05:24:05 EDT
+++ This bug was initially created as a clone of Bug #1272006 +++

Description of problem:
When session information is maintained outside Gluster, there needs to be a mechanism to retrieve files starting from a particular time-stamp. This specific requirement has been initiated by Open Source Backup and Recovery software: bareos

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2015-11-25 02:40:52 EST
REVIEW: http://review.gluster.org/12742 (tools/glusterfind: add query command to list files) posted (#1) for review on release-3.7 by Milind Changire (mchangir@redhat.com)
Comment 2 Vijay Bellur 2015-12-02 01:24:41 EST
REVIEW: http://review.gluster.org/12742 (tools/glusterfind: add query command to list files) posted (#2) for review on release-3.7 by Aravinda VK (avishwan@redhat.com)
Comment 3 Vijay Bellur 2015-12-11 03:29:16 EST
COMMIT: http://review.gluster.org/12742 committed in release-3.7 by Venky Shankar (vshankar@redhat.com) 
------
commit b21fa41b44097cf54d41aedd914457a2480d43cf
Author: Milind Changire <mchangir@redhat.com>
Date:   Thu Oct 15 15:01:23 2015 +0530

    tools/glusterfind: add query command to list files
    
    When session information is maintained outside Gluster, there needs to
    be some mechanism to list files starting from a time-stamp. This patch
    implements the feature via the "query" command-line option.
    
    The only caveat is that the first time the query command is run for the
    volume, it will likely report that "historical changelogs are not
    available". This is due to the fact that changelogs had not been turned
    on for the volume so far. So the volume options need to be turned on
    outside glusterfind or the since_time need to be greater than the
    current time when the query command is run for the very first time for
    the volume. The query command turns on the required volume options for
    collecting changelogs.
    
    Change-Id: I6cb7a57a5ecd166210e2eb4deede06d40ccfa996
    BUG: 1272007
    Signed-off-by: Milind Changire <mchangir@redhat.com>
    Reviewed-on: http://review.gluster.org/12362
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Aravinda VK <avishwan@redhat.com>
     (cherry picked from commit a56e32e19703c0fbe2cedebcaf5edc8a6307d5a1)
    Reviewed-on: http://review.gluster.org/12742
Comment 4 Kaushal 2016-04-19 03:47:08 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.