Bug 1272012 - Failed to install the pkg 'open-vm-tools-debuginfo' of the repo 'rhel-7-desktop-debug-rpms'
Failed to install the pkg 'open-vm-tools-debuginfo' of the repo 'rhel-7-deskt...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: open-vm-tools (Show other bugs)
7.2
x86_64 Linux
urgent Severity urgent
: rc
: 7.2
Assigned To: Richard W.M. Jones
Virtualization Bugs
:
: 1272887 (view as bug list)
Depends On:
Blocks: 1301891 1288337
  Show dependency treegraph
 
Reported: 2015-10-15 05:40 EDT by Li Bin Liu
Modified: 2016-11-04 02:51 EDT (History)
10 users (show)

See Also:
Fixed In Version: open-vm-tools-10.0.5-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 02:51:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Li Bin Liu 2015-10-15 05:40:06 EDT
Description of problem:
Failed to install the pkg 'open-vm-tools-debuginfo' of the repo 'rhel-7-desktop-debug-rpms'

Version-Release number of selected component (if applicable):
RHEL-7.2-20150904.0

How reproducible:
100%

Steps to Reproduce:
1. Register and subscribe the testing machine
# cat /etc/rhsm/rhsm.conf | egrep "^hostname|^baseurl"
hostname = subscription.rhn.stage.redhat.com
baseurl= http://cdn.qa.redhat.com

# subscription-manager register --username=stage_rhel_test_new --password='redhat'
Registering to: subscription.rhn.stage.redhat.com:443/subscription
The system has been registered with ID: da98a464-f7cc-44c0-9b7d-ebbd7b2e51eb  

# subscription-manager subscribe --pool=8a99f9814efa4537014efc8703aa048c
Successfully attached a subscription for: Red Hat Runtime

# subscription-manager repos --disable=*

# subscription-manager repos --enable=rhel-7-desktop-rpms
Repository 'rhel-7-desktop-rpms' is enabled for this system.

# subscription-manager repos --enable=rhel-7-desktop-debug-rpms
Repository 'rhel-7-desktop-debug-rpms' is enabled for this system.

2. Try to install the pkg 'open-vm-tools-debuginfo' of the repo 'rhel-7-desktop-debug-rpms'
# yum install -y open-vm-tools-debuginfo
Loaded plugins: product-id, search-disabled-repos, subscription-manager
Resolving Dependencies
--> Running transaction check
---> Package open-vm-tools-debuginfo.x86_64 0:9.10.2-3.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

===============================================================================================================================================================================================================
 Package           Arch           Version           Repository           Size
===============================================================================================================================================================================================================
Installing:
 open-vm-tools-debuginfo  x86_64  9.10.2-3.el7 rhel-7-desktop-debug-rpms 3.1 M

Transaction Summary
===============================================================================================================================================================================================================
Install  1 Package

Total size: 3.1 M
Installed size: 14 M
Downloading packages:
Running transaction check
Running transaction test

Transaction check error:
  file /usr/lib/debug/usr/sbin/mount.vmhgfs.debug conflicts between attempted installs of open-vm-tools-debuginfo-9.10.2-3.el7.x86_64 and open-vm-tools-debuginfo-9.10.2-3.el7.x86_64

Error Summary
-------------


Actual results:
Failed to install the pkg 'open-vm-tools-debuginfo'.

Expected results:
Succeed to install the pkg 'open-vm-tools-debuginfo'.

Additional info:
Comment 1 ldu 2015-10-21 22:39:39 EDT
Hi Richard,

I also met this issue in the tps-rpmtest, could you take a look at this bug?
It is RHEL7.2 snapshot5 now,will we fix it in RHEL7.2?
Comment 2 Richard W.M. Jones 2015-10-22 03:40:04 EDT
The error message makes no sense:

Transaction check error:
  file /usr/lib/debug/usr/sbin/mount.vmhgfs.debug conflicts between attempted installs of
open-vm-tools-debuginfo-9.10.2-3.el7.x86_64 and
open-vm-tools-debuginfo-9.10.2-3.el7.x86_64

The two packages it is comparing are identical.

Also this works fine for me:

# yum install open-vm-tools-debuginfo-9.10.2-3.el7.x86_64.rpm
Loaded plugins: product-id, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Examining open-vm-tools-debuginfo-9.10.2-3.el7.x86_64.rpm: open-vm-tools-debuginfo-9.10.2-3.el7.x86_64
Marking open-vm-tools-debuginfo-9.10.2-3.el7.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package open-vm-tools-debuginfo.x86_64 0:9.10.2-3.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package Arch   Version      Repository                                    Size
================================================================================
Installing:
 open-vm-tools-debuginfo
         x86_64 9.10.2-3.el7 /open-vm-tools-debuginfo-9.10.2-3.el7.x86_64  14 M

Transaction Summary
================================================================================
Install  1 Package

Total size: 14 M
Installed size: 14 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : open-vm-tools-debuginfo-9.10.2-3.el7.x86_64                  1/1 
brew/7Server                                             | 3.0 kB     00:00     
epel/x86_64/metalink                                     |  25 kB     00:00     
epel/x86_64                                              | 4.3 kB     00:00     
epel/x86_64/updateinfo                                   | 370 kB     00:00     
epel/x86_64/primary_db                                   | 3.6 MB     00:01     
libguestfs-RHEL-7.2-preview                              | 2.9 kB     00:00     
rhel7                                                    | 4.1 kB     00:00     
rhel7-optional                                           | 3.8 kB     00:00     
rhpkg                                                    | 3.8 kB     00:00     
  Verifying  : open-vm-tools-debuginfo-9.10.2-3.el7.x86_64                  1/1 

Installed:
  open-vm-tools-debuginfo.x86_64 0:9.10.2-3.el7                                 

Complete!

I suspect the TPS machine is broken in some way (see thread on os-devel-list@).
Comment 3 Richard W.M. Jones 2015-10-22 03:42:46 EDT
Also I can update to the -4 package:

# yum install open-vm-tools-debuginfo-9.10.2-4.el7.x86_64.rpm
Loaded plugins: product-id, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Examining open-vm-tools-debuginfo-9.10.2-4.el7.x86_64.rpm: open-vm-tools-debuginfo-9.10.2-4.el7.x86_64
Marking open-vm-tools-debuginfo-9.10.2-4.el7.x86_64.rpm as an update to open-vm-tools-debuginfo-9.10.2-3.el7.x86_64
Resolving Dependencies
--> Running transaction check
---> Package open-vm-tools-debuginfo.x86_64 0:9.10.2-3.el7 will be updated
---> Package open-vm-tools-debuginfo.x86_64 0:9.10.2-4.el7 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package Arch   Version      Repository                                    Size
================================================================================
Updating:
 open-vm-tools-debuginfo
         x86_64 9.10.2-4.el7 /open-vm-tools-debuginfo-9.10.2-4.el7.x86_64  14 M

Transaction Summary
================================================================================
Upgrade  1 Package

Total size: 14 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Updating   : open-vm-tools-debuginfo-9.10.2-4.el7.x86_64                  1/2 
  Cleanup    : open-vm-tools-debuginfo-9.10.2-3.el7.x86_64                  2/2 
  Verifying  : open-vm-tools-debuginfo-9.10.2-4.el7.x86_64                  1/2 
  Verifying  : open-vm-tools-debuginfo-9.10.2-3.el7.x86_64                  2/2 

Updated:
  open-vm-tools-debuginfo.x86_64 0:9.10.2-4.el7                                 

Complete!
Comment 4 ldu 2015-10-22 04:02:29 EDT
Hi Richard,

I had test this with the RHEL7.2 sp5,and the kernel is 3.10.0-324.el7.x86_64,this bug can reproduce.
and this bug not occur on the older kernel,just like the rhel7 3.10.0-302.el7.x86_64,Could you tell me which kernel do you used?
Comment 5 Richard W.M. Jones 2015-10-22 04:08:27 EDT
kernel 3.10.0-229.el7.x86_64

Seems unlikely this would be anything to do with the kernel ...
Comment 7 Richard W.M. Jones 2015-10-22 05:22:16 EDT
Turns out this is the same as bug 1190540.  The fix for
that bug was added to Fedora, but not for RHEL.

The fix is (part of) this commit:

http://pkgs.fedoraproject.org/cgit/open-vm-tools.git/commit/?id=41f57b8cdc74ab15f17bb0511d3df00a47ec37d5

I'll fix this in RHEL 7.3.
Comment 9 ldu 2015-12-07 04:06:02 EST
*** Bug 1272887 has been marked as a duplicate of this bug. ***
Comment 11 ldu 2016-07-20 03:17:03 EDT
verify this bug with RHEL 7.3 guest on ESXi 6.0 host.
Verify version:
kernel version:Linux rhel7 3.10.0-461.el7.x86_64
open-vm-tools version:open-vm-tools-10.0.5-2.el7.x86_64

Verify steps:
1. Install one new RHEL7.3 guest with the open-vm-tools version is open-vm-tools-10.0.5-2.el7.x86_64 .
2. Install the open-vm-tools-debuginfo with command:
yum install -y open-vm-tools-debuginfo  

The test result: Verified
Succeed to install the pkg 'open-vm-tools-debuginfo'.
Comment 13 errata-xmlrpc 2016-11-04 02:51:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2464.html

Note You need to log in before you can comment on or make changes to this bug.