Bug 1272021 - "undefined method `state'" when starting/stopping VM on vmware compute resource
"undefined method `state'" when starting/stopping VM on vmware compute resource
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Compute Resources (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: GA
: --
Assigned To: satellite6-bugs
Kedar Bidarkar
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-15 05:52 EDT by Antonin Pagac
Modified: 2016-07-27 07:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:13:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Antonin Pagac 2015-10-15 05:52:14 EDT
Description of problem:
When starting/stopping a VM on vmware compute resource, the operation takes a long time (~5 minutes), then the page loads and an error is displayed in a popup:

"Error - undefined method `state' for #<Fog::Compute::Vsphere::Server:0x007f72c8966d00>"

However, the operation is successful, VM on the vmware host starts/stops as requested.

Version-Release number of selected component (if applicable):
Satellite 6.1.3 COMPOSE 6

How reproducible:
Always

Steps to Reproduce:
1. Add a vmware compute resource
2. Click on Virtual Machines tab
3. Try to start or stop a VM

Actual results:
Operation takes a long time, in the end error is displayed

Expected results:
Operation takes less time, no error is displayed or success message is displayed

Additional info:
This is Satellite with updated fog gems:
ruby193-rubygem-fog-core-1.32.0-1.el7.noarch
ruby193-rubygem-fog-google-0.0.7-1.el7.noarch
ruby193-rubygem-fog-1.32.0-1.el7.noarch
ruby193-rubygem-fog-aws-0.7.2-1.el7.noarch
ruby193-rubygem-fog-json-1.0.0-2.1.el7.noarch
ruby193-rubygem-fog-xml-0.1.2-1.el7.noarch
Comment 3 Kedar Bidarkar 2016-05-20 09:12:04 EDT
This issue is no longer seen but upon trying to shutdown a vm, we see this message, during the confirmation dialog box. 

"Are you sure you want to power off #<FogExtensions::Vsphere::MiniServer:0x0000000ec28e78>"

Will try to track this is another bug.

VERIFIED with sat62-snap12.1
Comment 4 Kedar Bidarkar 2016-05-20 10:11:33 EDT
The other bug to track the mentioned issue is https://bugzilla.redhat.com/show_bug.cgi?id=1337949
Comment 5 Bryan Kearney 2016-07-27 07:13:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.