Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1272028 - "uninitialized constant Fog::Compute::OpenStack::Server" when clicking on VM on vmware compute resource
Summary: "uninitialized constant Fog::Compute::OpenStack::Server" when clicking on VM ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Compute Resources
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Kedar Bidarkar
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-15 10:12 UTC by Antonin Pagac
Modified: 2019-09-26 14:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 11:03:59 UTC
Target Upstream Version:


Attachments (Terms of Use)
we can now access the vm page by clicking it (50.70 KB, image/png)
2016-05-20 13:17 UTC, Kedar Bidarkar
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 12187 0 Normal Closed Warning! uninitialized constant Fog::Compute::OpenStack 2020-07-31 12:20:56 UTC

Description Antonin Pagac 2015-10-15 10:12:26 UTC
Description of problem:
When clicking on a VM on vmware compute resource, there is an error page displayed:

"
Oops, we're sorry but something went wrong
 
uninitialized constant Fog::Compute::OpenStack::Server

If you feel this is an error with Satellite 6 itself, please open a new issue with Satellite ticketing system, You would probably need to attach the Full trace and relevant log entries. 
"

Version-Release number of selected component (if applicable):
Satellite 6.1.3 COMPOSE 6

How reproducible:
Always, on any VM

Steps to Reproduce:
1. Add a vmware compute resource
2. Click on Virtual Machines
3. Click on any VM

Actual results:
The error page appears

Expected results:
Details of the VM should appear

Additional info:
This is a Satellite with updated fog gems:
ruby193-rubygem-fog-core-1.32.0-1.el7.noarch
ruby193-rubygem-fog-google-0.0.7-1.el7.noarch
ruby193-rubygem-fog-1.32.0-1.el7.noarch
ruby193-rubygem-fog-aws-0.7.2-1.el7.noarch
ruby193-rubygem-fog-json-1.0.0-2.1.el7.noarch
ruby193-rubygem-fog-xml-0.1.2-1.el7.noarch

Comment 2 Daniel Lobato Garcia 2016-04-22 11:28:02 UTC
Connecting redmine issue http://projects.theforeman.org/issues/12187 from this bug

Comment 3 Daniel Lobato Garcia 2016-04-22 11:30:07 UTC
Closing as ON_QA, it was merged a long time ago for 6.2

https://gitlab.sat.lab.tlv.redhat.com/satellite6/foreman/commit/7447c53153c79208f107bbd877009813bc8f20c5

Comment 4 Kedar Bidarkar 2016-05-20 13:17:42 UTC
Created attachment 1159901 [details]
we can now access the vm page by clicking it

We can now access the particular vm page by clicking it and this error is no longer seen anymore.

VERIFIED with sat62-snap12.1

Comment 5 Bryan Kearney 2016-07-27 11:03:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.