Bug 1272035 - Consume fix for "pvchange fails to find physical volume" in lvm pacakge
Consume fix for "pvchange fails to find physical volume" in lvm pacakge
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity low
: ovirt-3.6.1
: 3.6.0
Assigned To: Fred Rolland
Elad
:
Depends On: 1259587
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-15 06:33 EDT by Nir Soffer
Modified: 2016-03-10 11:19 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-10 05:34:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48962 master MERGED spec: Require newer lvm2 version for el7 Never
oVirt gerrit 48972 ovirt-3.6 MERGED spec: Require newer lvm2 version for el7 Never

  None (edit)
Description Nir Soffer 2015-10-15 06:33:17 EDT
Description of problem:

There is was a regression in lvm 117, causing second pvcreate call to fail
during create vg flow, because of stale /etc/lvm/cache/.cache file.

This was fixed in lvm2-2.02.130-2.el7.

This issue does not effect Fedora 21 and 22 since they do not have
the broken lvm version.

We will need to require this version on Fedora 23 when we support it.
Comment 1 Allon Mureinik 2015-11-10 09:27:00 EST
Moving milestone as the underlying fix (bug 1259587) will only be available in EL7.2.
Comment 2 Fred Rolland 2015-11-10 10:29:46 EST
Reducing severity as the problematic issue was not released in any official version of lvm2.

We will update the spec to 7.2 version when we will support it.
Comment 3 Allon Mureinik 2015-11-27 07:33:02 EST
Eyal, this fix was included in the ovirt-3.6 branch, which will be the basis for RHEVM 3.6.0.
Why did you change the target release?
Comment 5 Eyal Edri 2015-11-27 10:24:04 EST
moved to modified by mistake.
Comment 7 Elad 2015-12-10 04:16:43 EST
# rpm -q --requires vdsm |grep lvm
lvm2 >= 2.02.130-2


Verified using:
vdsm-4.17.13-1.el7ev.noarch
Comment 8 Allon Mureinik 2016-03-10 05:34:47 EST
RHEV 3.6.0 has been released, setting status to CLOSED CURRENTRELEASE
Comment 9 Allon Mureinik 2016-03-10 05:36:47 EST
RHEV 3.6.0 has been released, setting status to CLOSED CURRENTRELEASE
Comment 10 Allon Mureinik 2016-03-10 05:42:23 EST
RHEV 3.6.0 has been released, setting status to CLOSED CURRENTRELEASE
Comment 11 Allon Mureinik 2016-03-10 06:59:07 EST
RHEV 3.6.0 has been released, setting status to CLOSED CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.