Bug 1272064 - *-setup-plugin-ovirt-engine should depend on ovirt-engine 3.5 not 3.6
*-setup-plugin-ovirt-engine should depend on ovirt-engine 3.5 not 3.6
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity urgent
: ovirt-3.6.0-rc3
: 3.6.0
Assigned To: Sandro Bonazzola
Karolína Hajná
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-15 08:04 EDT by Ondra Machacek
Modified: 2016-03-11 02:33 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-11 02:33:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondra Machacek 2015-10-15 08:04:54 EDT
Description of problem:
package *-setup-plugin-ovirt-engine-3.6.0.1-0.1.el6.noarch.rpm has wrong dependency (ovirt-engine 3.6 instead of 3.5)

Version-Release number of selected component (if applicable):
build 3.6.0-16
rhevm-setup-plugin-ovirt-engine-3.6.0.1-0.1.el6.noarch.rpm

How reproducible:
always

Steps to Reproduce:
1. try to upgrade 3.5 -> 3.6 (yum update rhevm-setup)

Actual results:
Error: Package: rhevm-setup-plugin-ovirt-engine-3.6.0.1-0.1.el6.noarch (rhevm36)
           Requires: rhevm >= 3.6.0
           Installed: rhevm-3.5.5-0.1.el6ev.noarch (@rhevm35)
               rhevm = 3.5.5-0.1.el6ev
Error: rhevm-setup-plugin-ovirt-engine co

Expected results:
Success

Additional info:
Was OK with rhevm-setup-plugin-ovirt-engine-3.6.0-0.18.el6.noarch.rpm
Comment 3 Sandro Bonazzola 2015-10-19 04:53:50 EDT
Looks like a rebase issue. Eyal?
Comment 4 Red Hat Bugzilla Rules Engine 2015-10-19 06:58:23 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 5 Sandro Bonazzola 2015-10-19 09:18:08 EDT
Moved to downstream classification, being a regression only in downstream packaging.
Comment 6 Karolína Hajná 2015-10-22 06:01:18 EDT
Verified on 3.6.0-17 (rhevm-setup-plugin-ovirt-engine-3.6.0.2-0.1.el6.noarch.rpm)

Note You need to log in before you can comment on or make changes to this bug.